DEVONThink Crashing on Import

Further to my post yesterday about how to recover databases, I restored the 2 corrupted files from backup. I have 6 in my collection. I verified and repaired all 6 with “no errors found”. I peeked into a few of the databases and everything seemed ok except for changes made since last backup (naturally).

However, I’m back to the same issue I had when I first started having the file. I thought it was a simple corruption.

When I Import, or drag and drop, a file from outside into DEVONthink, DEVONthink halts on import. I force quite it after a bit, then restart, and I find it has corrupted. Orphaned files it says. It it unable to verify and repair. Seems to happen to any of the 6 databases I have.

New Information.

I created a new empty DEVONthink database. I the did File/Import, and DEVONthink crashes every time. It cannot import. Since import not possible, then Rebuild works to export, but then fails on import.

Date/Time: 2013-07-24 11:00:02 +0100
OS Version: 10.8.4 (Build 12E55)
Architecture: x86_64
Report Version: 11
Command: DEVONthink Pro Office
Path: /Applications/DEVONthink Pro
Version: 2.6 (2.6)
Parent: launchd [154]

Lots more from the crash available, but will only provide if useful to someone.

Close DEVONthink. Locate the preference file (should be at ~/Library/Preferences/com.devon-technologies.thinkpro2.plist) and move it to the Desktop. Launch DEVONthink - a fresh preferences file will be created. If the import problem stops, then there is a corruption in the old preference file, so do not use it.

If the problem persists, then close all open applications and shut down the machine. Restart. At the OS X login screen, enter your password but press shift-return rather than return. This will boot OS X without running any of the login items. Test DEVONthink. If the import problem stops, then there is possibly a conflict with a login item – either a conflict with DEVONthink directly or between OS X and one of the login items.

Crash logs are not useful for posting on the forum, but are very useful if you send them to Support.

I think the issue is sorted. Here’s what I did:

  1. removed the *.plist file. Restarted DEVONThink. Problem still there.

  2. went to second idea. Restarted, entered pw, held shift while then pressing RETURN for computer to login. Problem did not go away.

  3. Googled and found out that shift key was to be depressed until desktop appears. Did that. Problem not there. Now I’m faced with the issue of figuring out which login item was the problem. This a mystery since it’s been months since I made any changes to login items (other than any updates that might have been applied along the way).

  4. Restarted the machine while I pondered that question. Tried on spec DEVONthink. Problem no longer there.

THEORY: after removing the *.plist file I should have restarted. ??

  1. I opened all 6 databases and did verify & repair. All showed no errors but one. One database had an orphaned file that it could not repair. I tried and tried. I copied that database, and then on the copy I did a Rebuild. This time the import worked fine. I did a verify & repair on that rebuilt database and still one orphaned file that it could not repair. From the DEVONthink log, I took note of exactly which file was orphaned. It was in the Files.noindex/pdf/1/ folder. I simply deleted the offending file. Then did a verfy and repair on the database and it checked out clean this time.

Whew. Almost a disaster which was averted.