Devonthink Flashback Problem

Recently my Devonthink has been flashing back a lot. When I click on the database file to open Devonthink, it still works, but the database is not automatically opened when I open Devonthink alone. I have all my files in iCloud and Indexed an Obsidian database. Anyone else have this problem?

How do you close/quit DEVONthink? Did it crash? Or do you use macOS 12.3.x and later and disabled system integrity protection?

I will always keep Devonthink on
Unless it crashes, it will not be turned off
My computer’s system is 12.3.1 (21E258)
Will turning off system integrity protection cause a flashback? I seem to remember that it was turned off before

Does the “flashback” return after you “quit” DEVONthink? And does a re-boot of the computer help? (Both are good things to do every so often… system backups of DEVONthink files are best done when DEVONthink not running, and MacOS appreciates a re-boot every so often for clean up stuff, etc.).

@cgrunenberg is working to investigate the affect on DEVONthink if System Integrity Protection (SIP) being turned off. This work, from reading posts here, is ongoing and investigative so far.

You can check if it’s turned off on your computer by running the command in a terminal window:

csrutil status

Everything I’ve read about SIP, for example Apple Developer Documentation, suggests it’s a good thing to keep it “on”.

Actually we’re able to confirm that the disabled system integrity protection on 12.3.x causes the issue but there’s no known workaround. The system seems to send a SIGKILL signal which can be neither ignored nor caught.

So … translating into my speak … SIP should be “on” (which is default by Apple) to keep DEVONthink working properly? Am I interpreting that correctly?

If true, I’m not sure that a hardship for but a few.

That is right on 12.3.x, not sure right now whether it’s still the same on 12.4.

1 Like

I am testing this right now.
Since it doesn’t happen in a controlled manner, it’s a bit of a waiting game. However, we do not encourage disabling SIP regardless.

2 Likes

Thank you!!! followed your instructions no more crash within a week!!!

Great that it is fixed. To confirm, you re-enabled (to “On”) SIP protection?

And did it happen in the meantime on 12.4?

Yes!“On”

1 Like

No issues in 12.4 that I’ve seen.

Does anybody still experience this when using a disabled SIP on 12.4?