Devonthink freezes when syncing

Hello,

I have two sync destination. One one my hard drive, one on my server via webdav. When I try to sync the Devonthink database, the software freezes, and I’m obliged to force it to quit. I’ve tried the tool Check and repair without success. I have Devonthink Pro 2.8.2 on Mac Os X Yosemite 10.10.1.

Thank you
DEVONthink Pro_2014-12-08-125230_Mac-Pro-de-Laurent.hang.zip (110 KB)

According to the log DEVONthink was still busy, how long did you wait before killing the application?

I’ve tried again. After nearly two hours, my computer have paused all the opened applications, the swap being nearly at 20 Gb. I’ve quitted all the applications, leaving only Devonthink. I’ve tried to resume it, but it was always marked as not responding. Sync was not completed.
DEVONthink Pro_2014-12-08-141136_Mac-Pro-de-Laurent.cpu_resource.diag.zip (14.3 KB)
Mac-Pro.zip (22.4 KB)
devonthink.log.zip (848 Bytes)

Thanks for the additional logs! Please enter this in the Terminal…


defaults write com.devon-technologies.thinkpro2 DisableFilesystemEvents -bool TRUE

…while DEVONthink Pro (Office) isn’t running. Does this fix the issue?

It doesn’t change. I join new logs, along with snapshots of stat menu. Swap still goes up to more than 20 Gb, Devonthink takes up to 200% of the processor and 1.98 Gb of RAM.
devonthink-logs.zip (212 KB)

Could you please send me (cgrunenberg - at - devon-technologies.com) the file ~/Library/Application Support/DEVONthink Pro 2/Console.log? Thanks!

Can you send me ( ndouglas at devontechnologies dot com) a log of what happens when you try to sync?

You can enable logging by entering the following commands in the Terminal:

defaults write com.devon-technologies.thinkpro2 DTSyncDebug -bool YES
defaults write com.devon-technologies.thinkpro2 DTSyncDebugHigh -bool YES

And then the log output will be written to ~/Library/Application Support/DEVONthink Pro 2/Console.log.