DEVONthink keeps asking permission even if it has already been allowed

When I press the hotkey “Copy selection” to invoke sorter. no window popped up which is supposed to, and the icon of DEVONthink jumped, then it told me I should give the permission in Security and privacy system preference pane. but DEVONthink has already been allowed in this list.
Is this a bug? it’s kind of a little annoying.


I have tried to reinstall it and restart my computer. but the problem is still there

Does DT have Full Disk Access?

Which app are you copying from?

Yes, It have Full disk access.

I copy content from chrome.
Thanks for your question. I found this problem doesn’t appear in other applications.
It looks like this issue about the permission register about DEVONthink and chrome.

The problem is solved!
It’s not due to DEVONthink, and the reason is I change chrome’s “Info.plist” file to accept the custom scheme URL.
In detail, Sometime earlier I try to open chrome://exsention directly in Alfred. But the system told me it could find the proper application to open this kind of URL.

After some research, I reference this article about how to define a custom url-scheme for org-roam. So I do three steps

  1. add a Dict in ~/Library/Preferences/ like this
 Dict {
        LSHandlerURLScheme = chrome
        LSHandlerRoleAll = string
        LSHandlerPreferredVersions = Dict {
            LSHandlerRoleAll = -
  1. add a structure to chrome’s Info.plist.
			<string>Chrome protocal Url</string>
  1. /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -R -f /Applications/Goolge\

After these steps, I could open chrome://settings chrome://extension in Alfred.

But the automation problem occurred.

Thank @BLUEFROG reminder. I am aware the problem is not because of DEVONthink, So I disable step 2.

Then the problem is solved.

I apologize for my thoughtlessness。

You’re welcome and thanks for the clarification.
I will have a look in the morning… unless someone beats me to it.