DEVONthink not appearing in macOS Security and Privacy settings

I want to import email from Outlook, but unfortunately DEVONthink is freezing everytime I go to the import tab. I think this is because it is trying to interact with Outlook but doesn’t have the requisite permissions in the macOS Security and Privacy settings, under Automation.

Unfortunately DEVONthink isn’t appearing in the ‘automation’ window in the Security and Privacy settings, and so I was wondering if there was a way I could force DT to ask for the permission to automate with Outlook.

macOS should actually display an alert the first time DEVONthink wants to automate another app. Was there such an alert, did you deny or confirm it? In addition, which version of macOS do you use and in which folder is DEVONthink installed?

I do not remember seeing such an alert, or any permissions alerts. I am using macOS Catalina (10.15.6), and the DT 3.5.2. DEVONthink is in the applications folder.

A screenshot of the Automation preferences might be useful, thanks.

Sure, please find one attached.

DEVONthink can’t add itself to the Security & Privacy > Automation settings, it’s automatically added by macOS as soon as a request to automate another app is confirmed for the first time. Unfortunately macOS doesn’t add DEVONthink if the request is denied (a major shortcoming or even bug since Mojave, IMHO).

Does downloading the app from our website and replacing the installed app with the downloaded one make a difference?

I have just downloaded the app again and replaced the installed app with the downloaded one, and unfortunately I am still not seeing any permissions request, and DT is still not in the Automation settings. The app is still freezing whenever I go to the import section, so I don’t know how I can make a request to automate Outlook.

Could you please launch Apple’s Activity Monitor application (see Applications > Utilities), select the frozen app the list of processes, choose the menu item View > Sample Process and send the result to cgrunenberg - at - Thanks in advance!

Yes, I’ve sent the email. Thank you for your help.

Try this…

  1. Quit DEVONthink and Outlook.
  2. Open /Applications/Utilities/
  3. Paste: tccutil reset AppleEvents
  4. Relaunch DEVONthink and Outlook.
  5. In Outlook, select an email and choose the Add message(s) to DEVONthink fro mthe global script menu in the menubar. You should be prompted to okay the Automation request (hopefully, as this process sometimes doesn’t behave as expected).

Thank you, but my issue has been solved with a simple reboot. The problem was that the automation handling of macOS was freezing the app.

Glad to hear it!

my issue has been solved with a simple reboot.

And yet again, why we advocate rebooting devices at least once a week. :slight_smile: