DevonThink opens to blank screen

When I open DevonThink I no longer can see the application. It is a very strange problem that I have never experienced before. Prior to this DevonThink had been working well for close to a month.

When I open the application the status bar at the top of OSX changes to the DevonThink status bar and the application dot appears under the dock icon. In other words, everything seems to work exactly as it should. Nothing locks up. There is no spinning beach ball. There just isn’t anything on the screen. Whatever I was looking at before, whether it was the desktop, safari, or some other application, remains front and center.

All of the DevonThink menus seem to function properly. I can open preferences and browse all of the drop down menus from the devonthink status bar.

I have tried to play around with the settings and that doesn’t seem to do anything. I have deleted the application and reinstalled it to no avail.

I am running the newest version of Lion and DevonThink Personal 2.3.4.

Thanks for all your help.


If no view appears, choose File > New Window.

Suggestion: In Preferences > General - Startup, choose the option to open windows that were open on quit. That will restore the windows that were open the last time you used the application.

Thanks for the suggestion Bill. I have tried that as well as the option to “Open New Window.” Neither option does anything. I have the exact same behavior with each choice.

Thanks, Jake

I have also noticed that most, if not all, of my options in the menus are “greyed” out. Its seems as if my database is closed or missing. Is there an option to manually find and open my database? If so, where would I find this?


That sounds like an unregistered application, after the demo period has expired.

Please click on the app name in the menubar and choose the “About…” option. Does the splash screen show it as registered to your name?

If you have DEVONthink Personal, the database should open automatically when the app is launched.

If you have the Pro or Pro Office edition, you databases have the filename extension “.dtBase2” and will be in the location you chose when each was created - perhaps in the Documents folder.

The splash screen lists my registered name. I am running DevonThink Personal 2.3.4. It seems as if the database is not opening on its own. Any other ideas?

If I navigate to Application Support, DevonThink 2 and I move all the files from that folder onto my desktop, DevonThink starts up fine (but of course all my data is missing). If I move the files back into the folder and restart DevonThink the program refuses to show me a window.

If I move just the “backup” folder back into the application support folder then I am able to “restore from backup”, but, after restoring, all of my files give me a “missing file” error within DevonThink.

This is bordering on ridiculous. I USED to rely on DevonThink and at this point I guess I am going to have to request a refund and use another solution.

Your last post provides the clue. The database had become damaged and so would not open.

Move the database folder named “DEVONthink 2” to the Desktop.

Make certain that DEVONthink Personal isn’t running.

Now create a new folder named DEVONthink 2 at ~/Library/Application Support/.

To prevent confusion, think of the DEVONthink 2 folder on the Desktop as Folder 1, and the new DEVONthink 2 folder as Folder 2.

Copy (Option-drag) the contents of the most recent internal Backup folder from Folder 1 into Folder 2.

Copy (Option-drag) the folder named Files.noindex from Folder 1 into Folder 2.

Launch DEVONthink Personal. Hopefully, this has recovered a working database from a state prior to the time at which it was damaged. Note that any files added after the time the internal backup was created will be shown in an “Orphan” group after running Tools > Verify & Repair.

But what if the recovered database still had errors?

Quit the DEVOBthink app.

Remove all the contents of Folder 2 except for the Files.noindex folder.

Copy (Option-drag) the contents of the next most recent internal Backup folder in Folder 1 into Folder 2.

Launch DEVONthink and run Verify & Repair. If there are not errors, you have a working database. But if the database still has problems, repeat the above and use the contents of the oldest internal Backup folder.

Hi, i have almost same issue in Devonthink 3

it does not show the main window. Is there another tread where I can find a solution?

Welcome @rurbieta

Are you running a trial or a licensed version?

I´m running trial version with 109 hours left.
I uninstall as described in Bug with smart rules / Disappearing smart rules after fresh installation - #11 by vinschger found also archives from DT2 from a previous atempt. Now it appear!

Any advice for new user?

  1. It’s unclear why you’re quoting the file path from Bill.
  2. Why do you have over 645,000 files in the database, let alone in the Global Inbox? See…
  1. :man_facepalming:t3: Mistakenly quoted.
  2. :man_facepalming:t3: I import my documents folder. Do you have any advice on how to deal with old files if you want to start afresh?
  1. No worries! :slight_smile:
  2. Deleting a database can be done at any time. I’d suggest you create a new database to work with instead of filling the Global Inbox. You could move items between databases, though I would not suggest moving tens (or hundreds) of thousands of files via drag and drop between databases. I’d suggest you read the Help > Documentation > Getting Started > Building Your Database and the previously mentioned blog post, then rethink your approach.

Regarding the Global Inbox, I would suggest this, assuming you’re really starting afresh with it…

  1. Quit DEVONthink.
  2. In the Finder press Command-Shift-G and paste: ~/Library/Application Support/DEVONthink 3
  3. Move the Inbox.dtBase2 file to your Desktop.
  4. Relaunch DEVONthink. You should have a new empty Global Inbox.