Devonthink Personal and NeoOffice Calc

Last autumn I consulted about an issue with NeoOffice Calc spreadsheets (indexed in Dtk, not imported), which got resolved here but the solution no longer works. I may have been using Devonthink Personal version 1 or an early beta of v2. I’m now using the latest version 2.

When viewing a NeoOffice Calc doc I can see part of sheet 1 but when I click on the Text Preview icon I get a blank window saying “no selection”. I can’t toggle back to the non-text view.

And today I found a Calc file I’d created earlier this month. When I viewed it in Dtk the text preview and other icons weren’t even there. DTk can’t search in it and seems to display it in some kind of image format. I thought the problem might be with the font (Calibri) so I tried Trebuchet & then Verdana and reformatted the whole document, but nothing worked.

I’ve got a few recent Excel spreadsheets that display perfectly in the text preview, better than in the older Dtk. It seems that as NeoOffice moves forward the gap between it and Devonthink grows. Is there a solution?

DT uses quicklook to display content for most file kinds, and the quality and features depend on the the quicklook generators written by the developers of the program that created that file (Microsoft, Apple, etc.). The first thing is to do a quicklook preview of your file using Finder outside DT. If the quality is the same, then you’d need to look to the developer of the other program to fix their quicklook generator. NeoOffice has a plugin, NeoPeek, that handles quicklook for NeoOffice. Do you have NeoPeek installed and activated (and up to date)?

I don’t understand what you mean by the quality being the same in QuickLook. I’ve never had any problems displaying any kind of files in QuickLook, including NeoOffice files. The QL views look pretty much the same as the displays in DT and pretty much the same as the original document.

I searched for NeoPeek and all I can find is some old posts in the Trinity forum and the WikI (dating from 2007 & 2008). Some of them describe abnormal behavior with QL and NeoO 2.2.5. I’m using 3.0.2 under Leopard. It looks to me like the display issues in DT are related to Calc docs created or updated in NeoO 3.0.2. Older ones work fine. And it’s not a problem of appearance; I can’t access them in DT so I can scroll through the entire doc, and DT won’t search their contents.