Devonthink Pro Office window gets activated when scanning

Hi all,

I never have seen this behavior and is very, very annoying - it’s so annoying that I am already searching for alternatives to Devonthink as there is nothing that I hate more than apps, that are in the background and active themselves while I am typing in another App. But exactly that is happing now.

I have a Fujitsu ADF Scanner. And I have to scan a lot. I just put in my documents, press a button. They get scanned and are sent to Devonthink. And every time a new document is sent to Devonthink, the Devonthink Window gets activated and gets Keyboard-Focus. Oh man do I hate it!

Anybody can help?


Which window is actually activated, could you please post a screenshot? Is one of the options Preferences > OCR > Searchable PDF > Enter metadata after text recognition or Preferences > Import > Destination > Select Group activated?

I’ve had the same problem, and here’s the behavior I’ve seen:

Neither of those preferences you’ve mentioned are set. My import destination is global inbox.

When Scansnap Manager finishes the actual scanning and sends the PDF to DTPO, DTPO is activated and comes to the front. The item is added to the queue. I believe that whichever DTPO application window was most recently active receives focus.

My assumption was always that the handoff from Scansnap Manager to DTPO activated the app when it sent the file over, but I’ve never looked into it. When I’m home with the scanner, I can test exactly which windows receive focus.

Um, this is weird. In the last paragraph, “m y a s s u m p t i o n” (without the extra spaces) is being translated to “I disagree” when rendering.

with 2.7.6, i cannot scan anymore. (Brother Utilitiy scanning, than call DTPO Application)

Scans are performed, than the Devon Splash Screen pops up, then nothing happens,
scan is lost.
OMG, please Devonians, why are there always problems…

And why didn’t you, at least, PUT A INFORMATION WINDOW IN FRONT, staying in front, informing about what is going on, and NOT hide errors …
Once again, your classify technology is great, but your look and feel and user interface is really bul…

Ii is even dangerous. When I scan, i don’t check if the scan head been done, i always have been sure that DTPO does the work…

Does DEVONthink still get activated if you’re closing all windows or opening only the Activity window?

Failed OCR should be logged to Windows > Log. Could you please send the file ~/Library/Application Support/DEVONthink Pro 2/Console.log to cgrunenberg - at - Thanks in advance!

Just tried. I opened DTPO and closed all windows, including the activity window. I started scanning, and Scansnap manager was activated. Once that finished, it activated DTPO and opened the Activity window.

On subsequent scans, I left the Activity window open, and it still activated the activity window each time.

Hello, i sent you an email.
What happens since upgrade :

When scanning from Brother Control Center, this one activates DTPO-App, and this opens in a second instance (have two DTPO in the dock) , and then nothing happens.

Console when try scanning :
2014-06-02 03:12:12.117 DEVONthink Pro[422:707] *** WARNING: -[NSImage compositeToPoint:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.
2014-06-02 03:12:12.138 DEVONthink Pro[422:707] *** WARNING: -[NSImage compositeToPoint:fromRect:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.

Thank you

The most likely reason is that there are multiple instances of DEVONthink Pro Office installed on the computer.

I second Christian’s comment.

To further amplify it, we strongly recommend against having more than one DEVONthink application installed on a Mac. More than one could result in database damage if there is multiple simultaneous access to a database, and there will be confusion about which database is to receive content when destination is controlled by script or Service.

I have definitely only one Application DTPO installed.

I will downgrade to th previous version of DTPO this night. I am pretty sure that the problem began with the new version.


. DEVONthink should not open a second instance of the application.

Repeat the process so you have two instances running in your Dock. Then right-click one and choose “Options > Show In Finder” to reveal the location of the selected instance. Repeat this with the second instance in your Dock.

You indicate two instances of the DTPO icon in the Dock. That shouldn’t happen. Why?

I don’t know why this happens in the moment when i scan!

This seems to be the bug of the new DTPO version. Will revert to.5 and le you know.

No, it’s not a DEVONthink bug when you see a second instance of a DEVONthink app in the Dock. You have a problem not caused by DEVONthink.

I am sorry Bill, it is a bug of DTPO installer.

I found a 2.7.6 App here :

/Users/myname/Library/Application Support/DEVONthink Pro Office/DEVONthink Pro Office 2.7.6/DEVONthink Pro

This is the version that is running.

I did not put it there, it has been put there by the DTPO update installer, IMHO.

And this made the mess, i think.

I moved the out from /Users/myname/Library/Application Support/DEVONthink Pro Office/DEVONthink Pro Office 2.7.6 in the Application Folder, now everything works.

While the last automatic update performed by DTPO, for one reason or another, the DTPO installer didn’t move it there , IMHO.

Bill, as always, this must be a user error and not a bug. :confused:

Interesting. I’m running 2.7.6 and I have nothing whatsoever at the location in ApplicationSupport. I also ran the upgrade from within DTPO, so I didn’t run the installer manually. But whatever the installer is doing, is does not seem to simply put a second copy in place for everyone.

Didn’t or did, IYHO?


thank you for your post, i only saw the second part right now. If i had seen and done this earlier, i would have found this error earlier today :slight_smile:


I moved it in the Application Folder, some minutes ago.
While updating from 2.7.5 to 2.7.6, the installer did not move it there, this is obviously the reason for the problem.

I don’t know if this is MAcOS that bugged or the DTPO installer, but i didn’t touch anything in these locations before.

I now realize that by “it” you probably meant the Application folder, not the AppSupp folder.

I never paid attention to where DTPO might copy the update during the automatic install. Maybe it “installs” it in AppSupp and then moves it over to the Application folder;
and the “moving” is really “copy and then delete original”. And then, maybe something happened on your system, and the delete part fell through?