DevonThink Pro won't "hide"

For some while now I have not been able to make DevonThink Pro Office hide when I hit cmd—H or try to use the “Hide DevonThink Pro” command. Every other application I have hides on command, and there are times when I want to reduce screen clutter and hite DT Pro while I focus on something else … but it won’t.

The thing is that I use DT Pro constantly every day, so it is always running on my computer and with some 67 million words, it takes some time to launch, so I am not about to quit it at regular intervals.

Does anyone else have this problem? If so, what is the work around, or can you suggest a solution?

I look forward to any responses that resolve the issue.


i have the same problem from time to time, but haven’t figured out why or when it happens.

today it hides just like it should. other times, neither the key command nor the menu command makes DTP hide. i just minimize it when this happens but it makes me a little confused and stops my flow when it happens :slight_smile:

it does not happen with any other application

just to inform you that you are not alone :slight_smile:

Glad to know I’m not alone in this. I’m not inclined to minimise for a couple of reasons:

  1. I already have too much in my dock with typically 20 applications running at any one time.

  2. I usually have 3-5 windows open for DevonThink, and it’s too much hassle when all I want to do is hide them in a single command


Strange. I almost never Hide applications but instead switch using Exposé.

However, Command-H always Hides DEVONthink Pro Office when I invoke it. Just tested it several times. At the moment I’ve got 11 windows open in DT Pro Office, and one minimized to the Dock.

Do you mean Exposé, or Spaces, Bill? I don’t use spaces to Isolate my DT Pro windows because I am often cross referencing between documents in DT Pro, and others in TextEdit, Pages, OmniOutliner, InDesign, Merlin, Safari and others which I frequently need to see side by side. This can make it a pain to use Spaces, when I may also need to cross refer between those other applications.

Sometimes I just need to focus on one application and clear the rest of the clutter, even if only temporarily. That’s when DT Pro’s non-hiding problem is a pain. I would love to know how to sort it … but if you can’t replicate the problem, perhaps someone who has experienced the issue has an answer.


It happens for me too, from time to time. Usually it’s automagically fixed when you focus on DT using expose, focus on something else, then focus back on it.


I’ve had and have the same problem. DevonAgent hides ok.

The Expose work-around didn’t work for me, or I didn’t do it right.

I’m also using Spaces, but try to get DTPro in the first space.


I just upgraded to 10.5.3, and now hide (cmd-H) no longer works.

I immediately logged into this forum, and found this thread at the top.

Weird. As soon as I posted my previous reply, I tried cycling through the open applications using cmd-tab, but DevonAgent would not come back. I could chose the DevonAgent icon in the expose list but it was like I chose nothing, the original app remained “on top.” When I chose DevonAgent in the dock, likewise - nothing. I then clicked-and-held over the dock icon and chose one of my DevonAgent widows, and it opened. When I closed that window, the Finder was the in-focus application, not DevonAgent. I finally just Force Quit DevoneAgent, rebooted it, and returned to the forum to write this new reply.
Right now, cmd-H hides DevonAgent like normal. And chosing it with cmd-tab works too.

It’s happening over here every then and now too but it’s not limited to DEVONthink. Therefore this might be a rare Leopard issue.

Weirdly, since I started this thread, my “hide” command now works. The only difference is that I installed 10.5.3 overnight. I’ll see if it still works a few days from now, as I don’t plan to quit DT Pro in the interim. If it does still work, then maybe it is a glitch in 10.5.2 … but if that’s the case it’s strange that no other applications seem to have been affected, only DT Pro.

Likewise, not just DEVONthink, happens for me in random apps (oddly, most often Apple apps like Mail, Safari, and Finder itself) which lose focus, then regain it when using expose (works for me anyway). Happens with MacBook Pro and Mac Pro, both using 10.5.2. Haven’t seen it happen yet with 10.5.3, but then I haven’t had much time to play with it yet.


OK, this is happening to me also since I upgraded last week from 10.4.11 to 10.5.3 . I haven’t seen it occur on any other application (yet?). Hiding has not worked with DT Pro since the upgrade. I do not have Spaces activated. It IS a pain in the butt (although I guess Spaces could be used as a workaround).

DT Pro ver 1.5.2
OS 10.5.3 with all current Apple uppdates

Rollo, I don’t use Spaces. Between Exposé and Command-Tab I can switch applications easily and juxtapose the windows I wish to place side-by-side.

It happens to me constantly. And because I have DevonThink open all the time and maximized, it gets annoying when I have to keep clicking minimize just to get it out of the way. Restarting DT, restarting the computer, etc don’t seem to work. I had the same problem with the previous beta as well. I hope this gets resolved soon.

I must admit, this problem has now gone away for me since switching to DTPO 2.0, but it persisted for a long long time.