Devonthink server web interface cant display picture

Hi, I just found this problem, Not one of these images, but all of them cannot be displayed. what should I do?

likely the file is corrupted? maybe try looking at the page with Safari, or copy the jpeg to desktop and attempt to view in Preview.

1 Like

I recently tried DEVONthink Server very briefly, but like you, found it had this limitation (among many). The images were all valid, but wouldn’t display. I checked that the images were valid. I couldn’t find an obvious cause.


Hi, rmschne. These images were all valid :sob:

So am I :cold_sweat:

Probably useful to others if you gave a URL to the jpeg to confirm. Or explain how you concluded valid. I’m not at all saying not valid. Just trying to help steer to a resolution by getting info that helps other. If a bug in DEVONthink Server, then DEVONthink people can look into easier.

Hi, rmschne. These images can be displayed in Devonthink desktop version, Devonthink to go and Finder Preview. And as @mhucka said, he got the same problem. Not one of these images, but all of them cannot be displayed.

can your images be displayed in devonthink server webpage?

That’s a good start for de-buging help and info for DEVONthink. I suspect they still might find value in inspecting the jpeg to help figure out the issue. they might ask you to send a support request or something. Just because the file extension is jpeg, doesn’t mean much about the content of the file. clearly something different between how the displayed independent of the method used in DEVONthink Server. My hunch is different software in use for same previewing, but what I don’t know.

What kind of image actually? Is it a type that is compatible to browsers (e.g. JPEG, PNG or GIF)?

1 Like

From the screenshot they posted I’d guess that it is a JPEG (or at least DT thinks that it is one). Maybe it is in fact a HEIC?

1 Like

The extension is not always correct, especially in case of images imported from mobile phones. Checking it in the is more reliable.

1 Like

That’s why I think it important to take a peek at the actual file… (which still not offered by OP).

1 Like

Hi, Team, thanks for the reply.

I had checked these four types image in safari and google chrome, none of them were displayed. May be a bug in server?

Hi, rmschne. Many thanks for the kind and smart suggestions.

My first thought is the report of the image type was from the Devonthink app, which can display it, and the fail to display was in a browser. DT might have ID’d a jpeg2000 as a jpeg, and maybe the browser wasn’t able to display jpeg2000.

That’s not it, though. A jpeg that the Preview inspector id’s as jpeg, color model rgb, 72 pixels per inch won’t display in the DT server.

Curiously, PDF’s with embedded jpeg images display fine. That’s all I’ve used the server for. Presenting a PDF library and RTF notes for review by others.

I turned on insecure logins on port 80 (don’t do that!) and accessed a DT database via unencrypted http on localhost.

Tcpdump captured the dialog. What DT sent to the browser was a fairly short packet that I suspect signaled “you’re out of luck, buddy.”

It looks like a server bug to me. If I open a server-undisplayable jpeg in Preview and export it to PDF in the inbox, I can view the PDF version in the web browser.

I can’t view any jpegs.

What’s the file extension of these images? E.g. jpeg, .jpg, .jpe or .jp2?

Here’s a way to repeat the issue that I think gives you full end-to-end visibility.

Go to DEVONtechnologies | Devonian Times.

Right click on the image for the August 19 post and choose “save image as.” I did this with Apple Safari.

Save it to the DT inbox.

The image is easyfind.png. Devonthink (the app) will display it. Via the server’s web interface, I get “This document type cannot be displayed” in the preview window in the web interface.

But you can fix it, sort of.

Double click on the file, either in the Inbox in the desktop DT app or in Finder, which should open it in Preview. Use File->Export as PDF to save it as a PDF in the DT inbox.

Back in the web interface, click DT’s refresh function in the web UI’s toolbar area and the new easyfind.pdf will appear in the inbox.

Click easyfind.pdf and the image displays.

My guess, which would sound more credible after a few sixers of vintage Schlitz, is that the MIME type isn’t being recognized for images, or something like that.

The image data in DT is in good shape. You can view images in the desktop app or copy them to the filesystem and view them there.

I think the request to the server from the browser used these headers:

GET /?action=custommetadata&id=841C6E5B-3C52-42DF-B2E1-8F6AFF182D72&format=JSON HTTP/1.1
Host: titanic.local
Accept: application/json, text/plain, */*
Connection: keep-alive
Cookie: DTWebServerPluginAccessToken=1960309109CC4058B61E4CEC81BA3EC1
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.2 Safari/605.1.15
Accept-Language: en-us
Referer: http://titanic.local/app/devonthink
Accept-Encoding: gzip, deflate

The server returned with:

HTTP/1.1 200 OK
Set-Cookie: DTWebServerPluginAccessToken=1960309109CC4058B61E4CEC81BA3EC1; Max-Age=1800; HttpOnly
Content-Type: text/plain; charset=utf-8
Content-Length: 3
Access-Control-Allow-Methods: GET, POST, OPTIONS
Access-Control-Allow-Origin: *

The body of that return was:


Before those transactions, I believe the browser fetched a font with GET /app/fonts/icomoon.da3423dd.ttf HTTP/1.1

Note to those wishing to peek at the traffic - before you click the checkbox allowing insecure HTTP connections on some port, confirm your firewall doesn’t translate any inbound traffic to port 80 on your Mac. When you’re finished, turn off the insecure login option unless you really want it.

I captured the packets by getting the web browser ready for the click I wanted to study and then running this in a terminal window:

sudo tcpdump -s 0 -i lo0 -w dtdump.pcap tcp port 80

That file can be read with:

tcpdump -r dtdump.pcap -A

1 Like

This has been fixed for the next update

1 Like

Great news! Thanks for your efforts. DT just keeps getting better.