Devonthink Sorter

Hi all,

I’m having a little trouble with the Devonthink sorter. I had a trial version of Devonthink Personal installed, after which I purchased DTPO. I suspect that I may not have uninstalled DT fully, as the sorter has been acting strangely since the DTPO installation.

When I click on the sorter icon, nothing happens, yet when I alter the sorters settings in DTPO’s Preferences (i.e. unchecking ‘Visibility: Full’ box), the sorter icon reacts by becoming translucent. Yet I cannot open the sorter or add files to it.

I followed the instructions for uninstalling DT, but I fear I may have missed something. I also note the following warning in DTPO’s manual:

“Note: It’s definitely not recommended to install both DEVONthink Personal and Professional on the same machine. For example, both applications use the same Services menu shortcuts and Mac OS X would assign the shortcuts sometimes to DEVONthink Personal, sometimes to Professional. In addition, DEVONagent stores contents in DEVONthink Professional if it’s available, otherwise in DEVONthink Personal.”

Given that I haven’t yet started creating databases with DTPO, would my best bet be to uninstall the programme fully and then reinstall? However, that won’t have solved my problem re the original installation of DT, and I wonder if someone can advise as to how to check my mac for any errant files that I missed.

Thanks in advance.

I believe I’ve solved the problem.

Could you share what you’ve come upon? :smiley:


I first went to System Preferences and removed the sorter from the log-in items, then restarted my computer. Next I followed the detailed instructions for uninstalling DTPO:


To remove (uninstall) DEVONthink Pro Office completely from your Mac, trash the following files and folders (~ stands for your Home folder):

DEVONthink Pro Office
~/Library/Application Support/DEVONthink Pro 2
All DEVONthink Pro Office-specific scripts in ~/Library/Scripts/
All DEVONthink Pro Office-specific workflows in ~/Library/Workflows/
All DEVONthink Pro Office-specific scripts in ~/Library/PDF Services/
Dashboard widgets
Bookmarklets from your web browser
The reference to the global inbox folder in your Finder’s sidebar.

I then used spotlight to search for any and all items related to Devonthink and discovered several, which confirmed to me that I had made a mess of uninstalling the personal version DT. I deleted all of these and then erased all items in the Trash.

Restarted my computer and everything has been working fine since. Hope that’s of some help.


Seems that the need to uninstall DEVONthink to resolve some issue or another comes up with some regularity on the forum. Maybe DEVONtech should consider including an “Uninstall DEVONthink” program in the download package.

A good idea, it’s not the most straightforward of programmes to uninstall.

It might also be an idea to warn buyers that they should uninstall the trial version of DT if they plan on purchasing a license for one of the more advanced versions. I attempted (stupidly I’m sure) to enter my DTPO license into the existing DT trial version. I was politely told to download the DTPO software and enter it there, but I wasn’t warned about uninstalling first. Perhaps that step should have been apparent to me, but given that the message was able to tell me what version to get, it wouldn’t hurt or be hard to add a warning.

Not bad suggestions from either one of you. Hmm… thx.