Different pdf results with clipper and bookmarklet

I wanted to pull a web comic as pdf with the safari clipper, but it turns out that it lost the pictures (but not the title and backgrounds). When I took the comic with the pdf-bookmarklet it shows up in complete form (see screenshot). Is this a bug or inevitable?

Lates version of DTPO and Safari 10.

Could you please post a screenshot of the clipper? In the end both approaches use the same backend, therefore some options might be different or it might have been a temporary network issue.

Mhm, that’s a little bit crazy now. After repeating the procedure (while I´m making the screenshot of the clipper), it seems to work with the clipper. But then I repeated it again (after I tried with the bookmarklet (that works), I tried again, and it didn’t work. And I tried agian, and it didn’t work. Something’s going on here.

That website is: thenib.com/bad-blood

The site’s design seems to be problematic. I have gotten poor results from PDF, web archive, and even viewing the site in DTPO.