Disappearing PDF notes in DT3

Hi,

I’ve been having a recurring problem since yesterday where annotations on PDFs suddenly disappear. It seems to happen only on certain PDFs so far: I save, close the PDF, and all highlights and notes are gone. It doesn’t happen every time, but I made it happen at least 15 times in the last few hours to this one document as I tried to replicate the problem. I’m trying to see if there’s a specific trigger (certain characters in note, number of notes, syncing, etc) but I can’t find it. I don’t think it ever happened with just a highlight though, it seems to always be highlights with notes. I did ‘check file integrity’ and ‘verify & repair database’ and found no problems.

Now it seems not to be happening for a little even as I add more test annotations and keep saving the file. I realize that’s not a lot to go on, but for starters is this a known issue at all? (I found one inconclusive post from 2019.) And, can I pull up a detailed log or something to troubleshoot? I’m really terrified of losing annotations in this database.

thanks
Lucas

Are you syncing with another device, including DEVONthink To Go on mobile?

In addition, which version of macOS and DEVONthink do you use? Are the permissions of the PDF document restricted in any way?

Yes, I’m syncing with DTTG. I tried to test if that was the issue by annotating a different doc on both but couldn’t trigger it. I do notice that the note bubbles for annotations via DTTG don’t show up on the Mac, either in DT3 or Preview (but the notes are visible in the sidebar).

I’m on MacOS 12.7, DevonThink 3.9.4. The IpadOS is 17.1. It did just update yesterday I think.

I’d never noticed this until the last day or two and didn’t really confirm it until this morning. I did work a little more on the iPad the last couple of days but like I said I can’t seem to trigger the behavior deliberately.

Thanks for your help!

Re: permissions, I don’t think they’re restricted. If I pull it up in finder, I have read&write, ‘staff’ has read only, ‘everyone’ has read only.

You’re welcome.

  • Are you working on the same PDF in both DEVONthink and DEVONthink To Go simultaneously?

  • What kind of sync are you doing?

I only use the iPad when I leave the laptop behind. I sync before switching over but I guess it’s not impossible that I was offline wit the iPad and changes didn’t take. (But wouldn’t I get a conflicting versions notice?)

I’m syncing via the built-in Dropbox sync. (And these are imported PDFs not indexed.)

(But wouldn’t I get a conflicting versions notice?)

There are no notifications for sync conflicts. A document quietly either receives the latest changes or creates a duplicate document.

Ah right. DTTG is set to make duplicates.

What is DEVONthink’s set to?

Same. I haven’t changed either.

Hold the Option key and choose Help > Report bug to start a support ticket. Please attach the problematic PDF.

Okay thanks I will. It just happened again right now, same PDF. Maybe I can send current blank version and recover annotated version to send also?

That sounds good. Please drag them to the desktop and compressed them too. Thanks!

Hmm I guess I don’t know-how to do that since they’re outside of the regular dropbox sync records / versioning.

Compress them?

  1. Select the documents in the Finder.
  2. Control-click one while they’re both selected.
  3. Choose Compress and it will create an Achive.zip file at the same location.

I meant, I’m not sure how to recover the annotated version after it wipes. For a regular file in Dropbox you can restore a previous version but I don’t know how to do that for files in the DT database sync store.

HOWEVER, updates: by keeping the PDF document preview visible in DT while I work on it in its own window, I can actually see exactly when the annotations disappear (from the preview window) as I’m working on it. I was able to trigger it simply by highlighting text, adding an annotation via “add note,” and saving. The annotation disappeared on save. (Though like I said this doesn’t happen every time.)

I actually managed to record this happening with screenshot. I don’t want to post it because it’s a private meeting transcript. Anyway I will file the support ticket. Thanks!

1 Like

Send along the screencast with the ticket. Thanks!