disappearing sorter?

Hi all,

My Sorter has disappeared, and I can’t figure out how to restore it…

  • verified that Visibility is Full, and reset full screen apps
  • reduced from three monitors to one
  • trashed Sorter prefs, and, when that did nothing, trashed DTPro prefs too
  • removed any log in items added recently except one (see below), restarted
  • verified that the Sorter is being added to the log in items when I click the pref

One possible clue: I’ve noticed that if I check ‘start at login’ in the prefs, quit and re launch (with or without logging out/in), then when I check prefs again, it is unchecked. However, ‘Quit Sorter’ is still available in the DTPro menu (which seems odd).

Also, I have not removed the ‘iTunes Helper’ (iTunes 10) login item that is before the Sorter in the list - assuming (perhaps wrongly) that as an Apple app it should be okay - plus I don’t know how I’d restore it…

Anyone have thoughts on further troubleshooting?


DevonThink Pro 2.0.5, OS 10.5.8

Please quit the Sorter (either via the Dock or Tools menu), then delete its preferences and launch it again. Is the Sorter now visible?

I tried that again a few times, but unfortunately without success.

I can see in Activity Monitor that the Sorter process is quitting properly, and successfully relaunching (via the Tools menu) - and I’ve verified that ‘Full’ is selected under Visibility - but I still can’t see it anywhere.

I’ve also verified visually that the Sorter prefs are being re-created okay after trashing them and relaunching.

Very odd…!

Do you use WriteRoom or Spaces or are still multiple monitors attached?

Hi Christian,

I don’t use Spaces or WriteRoom. I do still have multiple monitors, but I had been testing it by mirroring (so all three displayed the same thing).

However, I just tried again after physically disconnecting the two extras, quitting the Sorter, trashing its Prefs, and relaunching. Still can’t see it (and visibility is set to Full).

The only display-related app I used is a little window moving utility called SizeUp, but disabling that has never made any difference either. Have also done multiple restarts too, but no success.

I didn’t realize how much I depend on the Sorter until this glitch!


Please try this:

  1. Quit the Sorter
  2. Delete its preferences ~/Library/Preferences/com.devon-technologies.think-sorter.plist
  3. Use only one monitor
  4. Restart the computer
  5. Launch the Sorter

That should definitely fix the problem. If not, did you install any third-party stuff or did you change anything lately?

Tried all steps again - no difference.
Disabled recent 3rd party app auto startups that might have coincided with the problem (SizeUp and Snapper) and repeated steps - no difference.

I regularly update my existing apps - some of which include background drivers (e.g audio drivers), so it’s possible one of those updates might have caused this - but unfortunately I can’t identify which ones might coincide with the problem, as I don’t keep track of those kinds of routine updates. And most of those would be difficult to revert.

I seem to have fixed it - though I’m not really much wiser about it…

I logged in with a Guest account, to see if the problem persisted there. It did - could not get the Sorter to display there either. At that point, I figured it had to be a corruption within the app itself, rather than user prefs.

So I deleted DTPro and prefs files (except registration), and reinstalled the app.

Everything is working fine again - returned to 3 monitors, restored recent 3rd party apps, restarted several times, all with no problem.

Here’s hoping it stays that way!