Document counts "zeroing"


#1

DTG (v 2.5 16250) has started zeroing the document counts in my databases. It did it to one database out of three on my phone first, and then started adding new docs to the count. But now it’s happened with a different database on my iPad. The documents are all there – in other words, it’s syncing files just fine – but it’s not displaying the totals correctly. The other odd aspect of this is that the iPad has picked up the erroneous total for one database from the iPhone. In the global scheme of things it’s not a disaster because I haven’t lost any data, but with well over a thousand docs, I do rely on the totals to check that it’s all synced.

At first I thought I’d just accidentally selected some filter, but the totals started adding from zero again. I’ve tried rebooting the desktop and both devices but I haven’t uninstalled DTG on both devices yet, which would be my next step. Both my phone and iPad are now showing different totals from each other (as in hundreds adrift, not just one file,) and neither show the same totals as the desktop. Any ideas? Or is this me missing something new in the latest version?


#2

Where are you getting the document counts for the databases?


#3

These are the screen shots. Bear in mind that these all consistently showed the same database totals before (as you’d expect if both phone and tablet were syncing with the desktop) and I haven’t changed any settings, views, or filters. I can’t recall when the last app update happened, but apart from installing that, I’ve touched absolutely nothing. I don’t actually work from the mobile devices – the phone version is only a backup in case I need something urgently when I’m away from my desk, and the iPad is a backup to that backup if the phone dies on me. I just check that the totals tally with the desktop each day, and suddenly… they don’t. But all the actual docs appear to be there. The iPad “all docs” figure is 33 higher than what’s actually on the desktop (I haven’t had time to work through them to find if there are really are more docs on the iPad) but all the documents are generated from the desktop. I don’t add docs via the mobile devices. They’re supposed to be mirrors of the desktop.

Images as follows.

Desktop is correct:
DT desktop.jpeg

iPhone had zeroed “Non-Writing” but has been adding docs synced after that.

iPad has now zeroed “Notes” and has somehow taken the “Non-Writing” total from the iPhone:


#4

Ths Sync icon has a triangle on it showing there is a problem. This would account for the differences. Touch it to see what the error is.


#5

As Jim mentioned, it looks like there may be a sync issue as indicated by the triangle on the sync icon. Also, you should note that the badge counts indicates the number of documents in the Inbox of the respective database, not the total number of documents in the database. Now if you store everything in the Inboxes, then that number may be the same. You can confirm the number of documents in the database on iOS by selecting the database, and then click on the ‘i’ in a circle to get the database info.


#6

Thank you for taking a look at it. The sync error triangle generally appears when it’s trying to sync at the same time as something else, usually when the desktop’s backing up DT to my backup drive via Dropsync. (DT is set to auto sync, Dropsync is set to sync whenever there’s a change.) That happens quite often and I check DTG to confirm that it’s trying to reach the server, then just wait until the backup’s done and connect again manually. Up until recently, it would then show the same numbers as on the desktop. It’s never affected the totals before. This is zeroing, not minor discrepancies, and I haven’t moved hundreds of files. I think I’m going to have to bite the bullet and reinstall DTG on both mobile devices. Like I say, it’s not a major problem because the docs are there, but mysteries bother me! :slight_smile:


#7

Right, that didn’t take as long as I expected. Uninstalled/ reinstalled on both phone and tablet, then resynced with the desktop. Everything is back to normal, with total displays identical on all three devices again. Absolutely nothing else was done except a fresh sync.

The good news is that it’s sorted, the bad news is that I didn’t work out what the glitch was before giving up, but I’ll keep an eye open for recurrences from now on and document them properly. Thank you all for your help.


#8

No problem, and yes, let us know if it recurs! :smiley:


#9

A year later, this problem is still recurring, alas. It’s now reached the stage where every sync zeros the database document count on both the iPad and the iPhone every time. I’ve tried to get around it by displaying All Documents as a smart group on the main screen, and that doesn’t zero, but I can’t find a way to display All Documents in the desktop version, so I still don’t have a way of checking that all the documents have been synced just by looking at the total.

When I go into the folders, the documents are there. The sync is set to automatic, but that seems to be erratic and I now sync manually from the device every evening as well to be on the safe side.

The zeroing has gone from occasional – sometimes when the app has been updated, sometimes for no reason that I can see – to every sync. I’ve deleted and reinstalled the app several times, and I’ve deleted the databases and resynced them repeatedly too, but nothing seems to cure it. Deleting and resyncing the largest databases is quite time-consuming so I’ve given up doing it to restore the totals because I know it’ll be zeroed again the next day.

I have DTTG 2.7.1 on the phone and 2.6.3 on the iPad (the latest version my model can run) but this has been happening regardless of version, not just after the most recent updates.

If I could display the All Documents total in the desktop version to check that the sync’s complete, I could live with it. But I can’t work out a way to do it. I thought I could do it by creating a new smart group and using a wildcard in the matches field, but when I create it, it doesn’t display anything.


#10

It’s unclear what the issue is.

If you are referring to the number after a database’s name on the Home screen… The number shows the number of items in the Inbox of the databases. it does not show the total number of files in a database.

PS: A global smart group could be created in the sidebar of DEVONthink with criterion of: Kind is Any document.


#11

The Any Document solution worked a treat. Thank you. That’s all I need to check that everything’s synced each time.

The issue isn’t whether the number is the inbox total or not, it’s that without my making any changes or moving documents, the totals revert to zero, and do so inconsistently. Here’s another oddity: I’ve just synced again, and on one device the numbers have gone back to the totals displayed on the desktop, but remain zeroed on the other one. But as I can now work from the documents total, I can live with that. Thanks again.


#12

You’re welcome. If there are discrepancies in item counts, you can try this…

  1. Press the Help icon in the bottom toolbar.
  2. Go to Appendix > URL Commands > Performing Service Tasks .
  3. Press the Execute link under delete-caches .

#13

I would never have found that in the normal run of things and – fingers crossed – the counts have remained correct on both iPad and phone since I cleared the caches. Thank you.


#14

You’re very welcome. :slight_smile: