Document selection when deleting/moving documents

I’d like to make a request to change which document is selected if I move/delete a document from a list of documents. As example, say I am working with a list of unread documents in a smart group. As a work down the list, I want to keep some documents where they are, and delete the documents I do not want. My hypothetical document list contains:

DocumentA
DocumentB
DocumentC
DocumentE

I have now viewed DocumentA which I want to keep, and I cursor down to select DocumentB, which I then want to delete. In the Finder or Path Finder, after deleting DocumentB the document selection moves to DocumentC, which is what I would prefer, and expect to happen. However, deleting DocumentB in DEVONthink always takes me back to DocumentA. Move down to DocumentC and delete it, and I am taken back to DocumentA again. This is not a big issue with a short list of documents, but is really quite annoying with a long list of documents that I am trying to work with using only the keyboard.

I cannot imagine why there would be a preference for DEVONthink to work the way it presently does, but perhaps I am overlooking something?

I probably misunderstanding and recreating this wrong, but I’m not seeing this behavior over here. For me, deleting a document in a list moves the selection to the next document in the list, if there is a next document, of if it is the last document that is deleted then the focus stays on the document that becomes the last document in the list. Here’s a video:

d.pr/v/aia7

(2.7.2 on 10.9.1)

You are not misunderstanding-what you see is exactly what I would like to see. However, it is not. Now if I could only find out what is different about my configuration (other than I have disabled the move to trash warnings).

cl.ly/0P0A3J2b0p0V

Has it always not worked?

Have you tried quitting, moving the preference file to the Desktop, then starting up with a new preference file?

I’m seeing the same behavior as korm. Maybe not helpful, but corroborating.

Hey, what the criteria of the Smart Group and the Sort on the results, Greg?

Looks like it only happens with smart groups, which I use primarily for this type of culling activity. I can have a group, sorted by name/ascending and a smart group sorted the same, and the document selection only jumps to the top of the list when deleting from the smart group.

Do either of you see the same thing when you are deleting from a smart group?

The video linked above shows deletion from a smart group, and the jumping behavior did not occur. However the smart group’ scope was not the entire database – in the video the smart group just searched the “documents” group.

I’ve now tested the scenario shown in the video but changing the smart group so that it looks in the entire database. The result is the same as what the video shows – and so I’m not seeing the jumping selector that Greg described in his initial posting in any smart group that I’ve tested.

(I wonder if sort order has something to do with this?)

BTW, this is a little more complicated with Mavericks due to changes in how app preferences are cached. More info here.

Basically, the simpelest solution that I have found to overcome this is to:

  1. Quit DEVONthink
  2. Delete, or otherwise move, the DEVONthink preference file
  3. In Activity Monitor, search for ‘cfprefsd’
  4. Kill the individual user ‘cfprefsd’ process (click on the ‘x’ in the toolbar for the individual user-DO NOT kill the process for root!)
  5. Restart DEVONthink

Note that DEVONthink stores a LOT of information in the preference file. You may need to spend a great deal of time recreating all the various Preference settings, column widths, etc.

Sort order doesn’t appear to make any difference, as I have tried multiple options with the sorting. Question-how are you deleting the document in the video? I am using command-option-delete, and I also have the trash warnings turned off. Command-option-delete (Move all instances to trash) is necessary in smart groups as command-delete (Move to trash) is disabled in smart groups. I wonder if this is causing the problem?

In the video: pressing the Delete key (on a 2012 MacBook Air).

I’ve subsequently found that “Move all Instances to Trash” in the contextual menu for selected item(s) in the smart group also works as expected.

Well, the delete key just beeps for me when a document is selected in a smart group. I created a new user account and the delete key works fine, so something is amiss with my primary user account. However, even with the new user account, deleting with command-option-delete pops the selection to the top document in the smart group.

Hmmm … I just now tried command-option-delete on the MBA and I’m not seeing the selection move to the top document. Just can’t make the selection jump.

Maybe you have a different kind of electricity over there 8)

Could be I guess! I might have to think about a ‘nuke and pave’ this week to install Mavericks fresh. I’ve always done that with every major OS release, even though most people say it is not necessary.

So, just reformatted my hard drive and reinstalled Mavericks. Using all the default preferences for a new install of DEVONthink, I see the following:

  1. The delete key still does not work in a smart group in the Global Sidebar, nor does command-delete. One must use command-option delete, and command-option-delete always jumps the document selection to the top of the list after a delete.

  2. The delete key does work in a smart group in the database, and the next document in the list is then selected (the behavior I would like to see). However, this is with the default option to give a warning before moving a document to the trash. If I disable the trash warning, then the selection jumps to the top document in the group, as I described in my original post. I don’t know if this is a bug or the intended behavior, but I would like to see it changed.

Here, I’m seeing that in this case I must use command-option-delete to remove a document – but the selection does not jump to the top of the list. The selector highlight simply vanishes.

I get the non-jumping selector regardless of whether the warning is enabled.

Agree: I would like (a) the delete key, the Move to Trash action, and Cut (command-X) all work the same way; (b) that the way they work is to immediately move the selected item to the trash; © that the selection highlight remains on the item just below the last deleted item (action (b)) or the last item in the list, whichever is true first, and (d) that these behaviors occur in every smart group – global side bar smart groups and smart groups in databases – and in every view that shows smart group contents.