Documents missing, will not download

I’ve found an issue that I’m not sure how to fix or why it happens. Several of my documents - emails, PDF’s etc say ‘File not yet available’ on the preview pane. I click the download button and there is a twirling cursor next to the button for a few seconds then nothing happens, the file is still not available.
There seems to be no pattern to this though most of my older documents are affected. One document, at least, only a year old is also affected. for some files I see a thumbnail, for others I see a generic icon.
Most of the items are in the same group but not entirely, this is my busiest group. All the items had been imported
I’ve no idea what to do now.

I’ve tried repairing the database, it says there is one error (1 file missing) which persists after repair.
I’ve tried rebuilding the database but that didn’t help

I’m using 3.7.2 Pro edition and Cloudkit

As far as the missing file is concerned, page 182 of the DEVONthink manual will tell you what to do about that.

Re files marked File not yet available, are they imported or indexed files? You may find inspiration searching for ‘File not yet available’ here in the forum; there are numerous threads on the topic. Specifically this could be relevant if you are indexing files in a cloud folder.

Where did the files originate - DEVONthink or DEVONthink To Go?

The majority, if not all, in DEVONthink. Most are quite old so I can’t be sure. The one from last year is definitely desktop

Thanks for your reply but unfortunately none of the information I have found helps with my problem.

None of the files are indexed from a cloud location (e.g. Dropbox, iCloud); note I’m not asking whether they are synced to a cloud location, but whether they are indexed.

In the original post I quite clearly stated the files were imported

Apologies, so you did - I missed that. Is the database itself stored on the internal drive in your Mac? Can you check the privileges on one of the files concerned (so, from the context menu select “Show in Finder”, and in Finder then from the context menu select “Get Info”; in Sharing & Permissions, does the section read something like “You can read and write” and “your name (Me) Read & Write”?).

Again, apologies for not having read your first post suitably thoroughly.

  • Are you also syncing with DEVONthink To Go?
    • If so, were you syncing with DEVONthink To Go 2?
    • Are the files available in the database in DEVONthink To Go?

The original database is on my iMac hard drive.
‘Show in finder’ is greyed out for these items


Yes, I am syncing
Yes, I used DTTG 2
No, they are not available there either


OK, I’ve got something odd going on
Following @Blanc 's request for Finder privileges and being unable to Show in Finder I did a search on my disk for some of the file names

Each one shows 3 instances, 2 within the DT3 folder

but with slightly differing addresses. The third is showing as being within Apple Mail, even for the files that have never been in Mail

If I double click on one of the found files it opens in a new window in DT3, the other two just show me the file listing in DT3 that produce the ‘File Not Available’

Does that help anyone with what’s going on? thanks

There are a couple of interesting things here…

I only have one entry in /Metadata/com.devon-technologies.think3/; and the files in the numbered subfolders don’t have plaintext names, but are of the format 123AB456-12A3-123A-12345ABC1234.dt3 or similar. These are not the records themselves, but metadata. The same is probably true for the file you found associated with the

I’ll be interested to see what Jim says to this; @BLUEFROG : are these just the spotlight indexes for those databases indexed by Spotlight?

The records themselves are contained within the database, and won’t be found by a simple search, because the contents of the database file won’t be indexed, I don’t think. You can view the contents of the database files, although you should never change anything if you do. If you select Show Package Contents from the context menu of the database file in Finder, it will open up, and you can (only then) actually use search to search inside it.

Do you have a feel for when this happened? Can you link it to any other occurrence around the same time? Do you have backups of your databases? Whilst I don’t know what’s going on, my next step would be to make a copy of my current database(s) and then put back a backup; I would choose to deactivate sync before doing so, although I wouldn’t clean the sync location yet (it might still have useful data). Obviously, Jim may have more helpful suggestions.

Yes. .dt3 files are Spotlight metadata, nothing more.
From the Help > Documentation > Windows > Database Properties > General > Create Spotlight Index

I have no idea when it happened. I only discovered it when I tried to open an old file I needed.

I’ll have a think about your suggestions for using a backup, I was hoping there might be a straightforward option that I’d missed.


There’s none that’s apparent to me, at least. If the files actually are in the database, then I would have assumed a repair/rebuild should work. If the files have gone missing from the database, then I have no explanation whatsoever.

Maybe somebody else has an idea?