Does DTTG search finder comments?

Either I’m doing something wrong or DTTG doesn’t search the Finder comments? I see the phrase:

ASCRS 2022

in the info portion of the DTTG item. But if I type “ASCRS 2022” in the search it doesn’t come up.

Just typing only searches in names. You need to tap „Search“ at the bottom right to search everything.

Thanks for the quick response! But I must be blind I don’t see any search field on the bottom right. Only the one above the Inbox

Still not working. Even after pressing the search button (iPad screenshot)

Finds it in my Mac, not on iPad see below.

try to see whether it works with comment:"ASCRS 2022 reservation"


FWiW, searching for comments in DTTG works fine here, just tested it with a test document and a unique comment added to then document. As a FYI, this was all done on an IPad, so not a true ‘Finder’ (macOS) Finder comment.

Actually, typing also searches contents. It just returns names first.

Also, pressing the Search button removes an assumed wildcard at the end of the last search term, treating it as a complete word.

@mmoran : When was the comment added ?

1 Like

Then I would try ? > Help > Appendix > Utility URL Commands > reindex-metadata

It takes some time for reindexing to complete.

It was added as a finder comment on my Mac and the sync’d using iCloud (CloudKit). I can see the document and the finder comment on both my iPhone and iPad but it doesn’t find the document when I type in the finder comment in the search bar and hit the search key.

does it find any other token (content) in that file? maybe a missing index could be the problem.

@Airestocky - it’s an OCR’d PDF and it will find any text in the PDF and I can find it by title.

Have you tried reindexing as I suggested?

1 Like

I haven’t tried re-indexing as the database is fairly large, but I will now. I don’t have good confidence that will help. Database is sync’d among 2 mac’s, 2 iPads and an iPhone. The Macs find it no problem, all the iOS devices do not, so that would be all 3 DTTG’s are not indexed properly? I’ll give it a try.

The index is independent, not shared.

Ok tried the re-index thing. I’m assuming it finished (I didn’t get any feedback on the screen when it finished). I just waited an hour or so - still not finding the entry.

Completely close DTTG (upwards swipe from springboard) and reopen it, please. It may be the case that reindexing will not take place until you have done that (weasel statement from memory somewhere in the back of my brain)…