Don’t remove RSS article if it’s currently open


Recently, I’ve started using DT’s built-in RSS features, and I’m extremely happy with it. The only minor issue for me is that sometimes DT deletes the article when I am actively reading it.

Here’s a screenshot of my settings:

Because the article is automatically marked as Read seconds after I start reading it, DT will proceed to delete it if it’s older than one day. I assume this is the currently expected behavior rather than a bug.

My request is to tweak the current behavior so that DT only remove articles that are not open. Thanks!

This should actually be already be prevented. Are you sure that the article was neither deleted by a smart rule nor by the sync?

Hi Christian, thanks for the reply!

That’s surprising to me. I just verified that I only have two smart rules that file away PDFs into specific groups, so they shouldn’t have anything to do with deleting news articles. As for sync, I currently do not have any sync locations enabled.

Further details that may or may not be useful:

I do not read RSS in DT every day, so the articles always vary in age each time I read them. Given this situation, I can’t say for certain that the issue has happened to every article older than one day, but it does happen several times during each reading session.

I’m not seeing that behavior here on Catalina.

However, @cgrunenberg: If you have set a format other than Automatic and there are a bunch of pages to download, you can’t cancel the activity.

I’m running DEVONthink 3 Pro edition version 3.8.2 on macOS Monterey 12.2.1(21D62). I’d of course be glad to provide further diagnostic info if necessary.

It’s actually intended that certain automatic activities can’t be canceled.

E.g. you could disable the actions of your smart rules (see sidebar’s contextual menu) to check whether it’s caused by smart rules.

Both smart rules start with All of the following is true: Kind is PDF/PS so it’s unlikely, but I definitely will double-check just to be sure. I’ll post the results in the next 24 hours.

You could also disable the automatic/scheduled sync if you use multiple Macs.

I only own one Mac, and currently I don’t have any sync locations enabled on it. During my limited testing today after disabling the two smart rules, the issue has not happened.

I’ll keep those two rules disabled and do some further testing for 2 or 3 days, since I was sure the issue couldn’t possibly be caused by them.

I see exactly the same behaviour on Monterey 12.3. - no sync, no DTG just a single installation on only one Mac. As a work-around I changed the removal time to After one week instead of After one day

which is ok for me.

Was the article opened in a main window or document window?

In the main windows. I normally don’t open document windows.

Are you still able to reproduce this using the latest version (3.8.3)?

I have to install 3.8.3 first, I’m still on 3.8.2 - will answer tomorrow.

Just updated to latest 3.8.3 switch back to “Remove articles: After one day” and it seems to be ok now. I have some unread RSS messages in the main window and they don’t disappear anymore.

Btw. congrats great release, like the JSON export and PDF split.

A little off-topic but may I ask what you intend to use this for?

Yes, I write almost everything in Markup language and use a header like this in every document:

Author: Thomas Krampe
Title: Titel
Organization: KNGSTN
Copyright: 2022 by 

With “export metadata as JSON” all of these information and some other (like uuid and md5 hash) are now in a small json file which I use in our company wide document management system. I just add some additional values in that JSON and post it via a API call to our self developed DMS.

1 Like

Very nice! Thanks for sharing :slight_smile: