Download Manager seems buggy

I have just moved up to DT Pro and am trying out the Download Manager (the site mirroring feature is one of the main reasons I want to upgrade).

When I add a valid URL to the list (e.g.,, to name two I’ve tried), it briefly appears, with the note "Loading . . . ", then disappears. Nothing seems to have been downloaded (there are no new files in my download target folder nor are there any new files in the database). The status message at the bottom still says “0 items (0 active) - 0 done.”

Also, sometimes when the new URL pane is open within the Download Manager window, I enter a new URL and then can get no response by pressing the “OK” button or the Enter key. The only way to get out of the window is to press the red close button at the top left.

Finally, when control-clicking on a Web page within the DT browser and choosing “Add Page to Downloads” seems to have no effect.

Any thoughts?


I’m seeing the same behaviour. I’ve tried entering a bunch of different web addresses, and tried a number of options.

The status goes from Queued, to Loading, to 0.0 KB. Nothing shows up in my download folder, nor my fresh new blank DT Pro 1.2 database.

I checked the console.log and system.log for messages and found nothing. Is there some other kind of history or log I can check for problems?

Also, something seems to remember all the web addresses I’ve already attempted. If I try the same site a 2nd time (even with different options, or in a brand new empty database), it just beeps when I press ok.

many thanks.

The Download Manager does work. Check out the information about it in Help (Help > DEVONthink Pro Help. Search for “download manager”.

There are a number of options, and you probably will need to experiment with settings to see what happens. (Click on the “cogwheel” and then on Options to be able to see all the possible settings.

I would suggest that you create a target folder on your Desktop to receive the downloaded material (rather than send it to your database) while you are experimenting.

At the risk of pointing out the (psuedo)obvious, do the downloads show up in the /Archive group?

I was convinced the Download Manager was broken until I manually downloaded (via firefox) the same PDFs I had downloaded via DT, imported them, and noticed they were duplicates. A ‘See also…’ to find the duplicates showed that they were all stored in the root-level group named ‘Archive’, which I didn’t expect (kinda figured they’d be in /, my incoming notes folder, or the current group), though I hadn’t read the docs on the download mgr either.

V1.2.1 will fix some bugs of the download manager.

I want to report the same problem.
Now i am able to dload something but i really don’t know how i did it :smiley:

If i play with presets i’m stuck into dload nothing maze :frowning: