Drag and drop selected text into a group doesn´t work

I tried to drag and drop selected text snippets (highlightet with my cursor) from a web page (Safari) into a group (in the group pane) (like it is desribed in your tutorial)

Unfortunatley, it isn´t possible to drag this selected text. Everytime I want to grab the highlightes text with the cursor, the highlifgting vanishs and it start a new selection from the cursors position.

Did I misunderstand something, or is there something that I have to set?

Thanks in advance.


I’ve just noticed this in some cases too and it seems to be website-specific. Disabling JavaScript might fix this annoying behaviour.

I disabled Javascript but this changed anything. I tried this in DevonAgent also, nothing changed.

To drag and drop didn´t worked in any case, instead of one, what means it works near to never.

It´s a pity because I thought, as you describe it in your tutorial, that this feature would work well.

Does anybody else made this experience?

Would be nice to hear how you handle/solve the problem?

There are two workarounds if dragging the selection of a website is not possible:

  1. Take a rich note
  2. Copy the selection, then use the “New from clipboard” submenu of DEVONthink’s Dock menu to paste it to the desired destination

This is what I hat did before I read your online tutorial.

Unfortunately, I have to come back to the old procedere.

Kind regards


Meanwhile I have asked a forum in the german mac-platform called macnews.de.

And here is the solution: It depends on the way one select and drag the text.

It works (in my case) when I select the text, click, wait and hold the cursor and then drag the text.

When I do this too fast, it don´t work.
Now it works everytime.



Thanks for that little tip. I wondered about this too. I did think it was a matter of waiting before dragging, but once I waited and dragged and I still lost my hightlighting, so I thought this was wrong. But I’ve just tried it and seems to work just fine. Perhaps that one time I tried it was an anomaly. Very handy, thanks again!

You could try this little terminal-hack:
macosxhints.com/article.php? … 1074003638
which changes the delay-before-dragging in cocoa apps.

Hi Jonas,

although I´m not familiar with the terminal I try it and it seems to work well.

Now, dragging works like it ought to be.

Thank you for this nice tip.