DRM-free epubs marked as "unauthorized"

I have a list of DRM-free epub files I bought from Humble Bundle that display fine in DEVONthink the 1st time I click on them, but are marked as “unauthorized” after that (exact message in French localization is: “Vous n’avez pas l’authorization d’accéder à la ressource requise)”. Those same files display fine in macOS books, Calibre, or any other ebook reader I tested.

Do note that I seem to have 2 problems:

  1. In some cases, removing the URL in the file’s metadata was sufficient to make the file readable
  2. In other cases, even with the URL removed, I still get the same error message.

I can provide the actual files privately for debugging purposes, but I won’t post them here for copyright reasons.


Welcome @fcharron83
How large are the problematic files?

My databases currently have 2169 ePubs, some of them with DRM removed by me, and not any complain. Are you sure those are standard ePub? Could you verify one of them with Calibre? You have some plugins that are able to do it, like Quality Check, EpubCheck or Check Books.

Apart, Calibre has the option to edit an ePub, and the possibility to check for inconsistencies. You will wonder how many issues en ePub can have, even those supposedly made by professional editorials like the big ones.

I have one that is 6.1MB, for instance.

Thanks for the plugin suggestions, I didn’t know about them.

I did install Quality Check, but found it quite a bit difficult to use, since you need to run each check individually. I did however run the DRM check on my books and it found no DRM.

I also installed the command line version of EpubCheck, and it didn’t report any error, warning or other info for the book I’m using for testing, which gives the error in question. I’m happy to generate a report with EpubCheck or any other tool, if it helps diagnose this problem…

Well, after trying out @rfog’s last suggestion (to edit the problematic ePub in Calibre, and using its own checking tool), I indeed found and fixed (sometimes by painfully applying hundreds of manual fixes to a single file…) all problematic books, and they now load properly in Devonthink.

I guess the only thing that could be improved is the error message that I was getting, which led me to think that the reason why the books weren’t opening was DRM, whereas it was in fact ePub structure errors (mostly typos in CSS, missing generic fonts, and wrong MIME type).

In any case, I’ll leave it to you @BLUEFROG to decide whether to improve the error message or not. My own issues are now resolved :slight_smile:

Thanks again @rfog for the help :wink:

1 Like

This sounds actually like an error message of the WebKit (used to view the HTML of the EPUB), not one of DEVONthink. Therefore a copy of one of the original files to reproduce the issue would be great.