DT 1.9 copies into database folder

Hello

I disabled every copying into database folder in the settings (Link to originals). Then I did an index but it still copied certain files (class, ps, eps, au so far) to Files/ in datebase folder. Is this bug or do I missunderstand something?

EDIT: It’s the same with import.

Best,
Hans

Hello

I found this happend only on read-only media. I have some compressed .dmg I’d like to index, but if DT copies this stuff to the db folder it makes no sense.

EDIT: This is wrong. But if I import these files being on my desktop, DT doesn’t copy them.

Best,
Hans

Hello

It seems to copy these files only in this particular path context. I could upload a .dmg which shows the problem.

Best,
Hans

Hello

It still doesn’t work!

Best,
Hans

Check the files types that DT can properly import. I don’t think you will have any luch with .dmg (compressed or not) files.

If the .dmg files contain importable files (text, rtf, rtfd, HTML, PDF, PS, .doc, .jpg etc.) those files can be imported into DT PE 1.9a – but you will have to move them out of the dmg to do that. Example: Set DT preferences to import files (e.g., PDF & PS, images, QT) to the database Files folder, mount the dmg, and either drag the files to DT or use Files > Import > Files and folders.

Hope this helps.

I don’t want these files to be copied into database folder. As I selected in Preferences -> only reference. DT 1.9.1 still copies randomly files into datebase folder under Files/. It is not a consisant behavior some files of the same type are copied others not.

Some files are always copied as they’re temporary, e.g. email attachments dragged from Apple’s Mail or PDF documents printed to DEVONthink.

In addition, there are separate settings for PDF/PS, Quicktime, images and unknown files and maybe one of them is still set to copy.

It just copies a tenth of my pdfs into Files/ so they are redundant on my HD. I don’t want this. Certainly not because I’m just indexing, I see no reason to copy anything while indexing. Sorry for being so insistent, but I’m sure there is something wrong.

Well, indexing shouldn’t copy anything. Could you provide me an example path of a document that is copied?

Here is an small image containing files that are copied while indexing:

fangorn.ch/dw/selfhtml.dmg

There are no pdfs in this image. If you need one with pdfs I have first to compile something since at the moment the folder I index contains private stuff.

Best,
Hans

I’ve just indexed this volume using the default settings of DT PE and no file was copied. Could you send me your preferences file (com.devon-technologies.think.plist) to check this using your settings? Thank you.

I tried with a lot of different sittings, my latest settings are here:

fangorn.ch/dw/com.devon-technologies.think.plist

Hans

I just indexed with default settings it happend again. You know, I’ll create a new db index with this stuff and send the db to you.

Here is my database fangorn.ch/dw/DEVONthink.tar.bz2. It is created with default settings (I stopped devonthink delete preferences and restarted it)

Well, your indexed database looks somewhat different than mine. Unfortunately I can’t access your preferences (error 403 - permission denied) and therefore it’s difficult to tell what’s causing the difference at the moment.

it works now: fangorn.ch/dw/com.devon-technologies.think.plist

Finally found the problem - the files you’ve indexed were temporary files (path “/tmp/…”) and then DT always copies images, PDF/PS document, movies/sounds etc.

So I have to mount them the images in a different directory?

I don’t know how you’re usually mouting images but the path to files/folders inside disk images should definitely not begin with “/tmp/…” (instead the path should look like “/Volumes/name/…”)