DT 3.91 Editing PDF documents not working anymore

Using DT 3.91:
Editing PDFs does not work any more, neither in the context menu (greyed functions) see attached screenshot, nor using editing features in the bar above the document.

It is not a problem of the document – editing with PDFexpert works fine,

Bildschirm­foto 2023-06-04 um 21.07.00

This has already been reported. Please search for forums before making new posts to confine the discussions.

Of course, I did a search before posting, but with no result.
I did a second attempt after your objection, again without success.
What would be the search term ???
Please provide me the link.

I do not agree.
The title “OCR/PDF conversion no longer works” is a pretty different issue that my observation “Editing PDF documents not working anymore”.
How should I know that it is probably the result of the same error in the PDF system?

Back to the initial subject:
So, the issue will be addressed.

1 Like

I think I got the same problem.

I just upgraded to 3.91. And the PDF file I downloaded was editable before, but not I cannot highlight it. It is very annoying and I am not able to continue my work. Is there anyway to solve this or downgrade to 3.90?

Thank you very much.


See hidden preference ForceEditablePDFs in the appending of help.

I’ve searched the relative info about ForceEditablePDFs. It is definitely helpful!

Thank you very much cgrunenberg!

Best regards,


I assume that you are working on a fix
and that enabling this option is a temporary workaround to be able to edit all PDF.

Is this correct?

It’s a workaround for a bug of the PDFkit framework to prevent corrupted documents, like most workarounds it has its shortcomings.

So, are you working on a fix, so that we can edit PDFs within DT like it was in the past?

If yes, I would continue with the current workaround, just opening the non-editable PDFs in my external app (PDFexpert).

There is some modification happening, but there is no “this will make all PDFs editable” fix to be had at this point.

Why don’t you enable the hidden preference? The only difference of the current version is that more documents are marked as read-only but editing/saving is still the same.

My 2 cents, not Herb’s. Is that if you guys the developers decided that by default more documents are now riskier to edit in DT why I, the mere user, would override it and increase my risk. Just doesn’t feel right, like a leap of faith—but then if I’m told to take it why isn’t on by default for everybody. There isn’t enough information on my end to understand the risks.

I think all that is also the reason for the question of whether there is work being done to reduce the amount of documents marked read-only as they were before. The current situation feels like a regression, even if edit/save didn’t change.

1 Like

As a user, I am confused.
I am reluctant to study PDF Kit behaviour and hidden preferences, to understand the consequences.

DT is a really great tool, but it is annoying that the PDF editing function is causing problems.

So, I agree with @fcy

What happens now?
As a user, do I have to screw around with the settings and cross my fingers?


The settings you are reluctant to use are not hidden since they are documented in the “DEVONtbink Manual” and recommended.

Best to take @cgrunenberg’s advice. he is a DEVONthink guru and developer.

Please watch my words, I am not reluctant to using the feature, but I am averse to spending time studying the case to understand the implications and furthermore, to figuring out how I change a hidden preference.

BTW, cgrunenberg himself called it a hidden setting.

Did I understand the following correctly?

  1. Apple has once again been playing with the PDF kit.
  2. Enabling ForceEditablePDFs will make most files editable, but I have to expect that the risk of damaging PDF files will increase.

In case, I want to use the preference ForceEditablePDFs, how do I turn it on?

Hi Herb

FWIW, a fix that is currently working for me is:

  1. Convert to PDF (Paginated) (→ still can’t highlight)


  1. OCR to searchable PDF (→ can now highlight).

It may not work for you but may be worth a try.

Previously Convert to PDF (Paginated) would usually fix the issue, but for some reason it is no longer fixing.

The only difference of the latest release is that the detection of those documents which might get corrupted by the PDFkit is a little bit too ambitious (and this will be improved in the next release again). That’s just to prevent data loss, other apps (like Preview) don’t do this at all and just silently fail.


The same problem, from 3.9.1 can’t highlight/mark text in PDF anymore.
Sorry, but I can’t understand the resolution after reading all the above.
Should I wait for an updated version? This was one of my favorite features.

1 Like