DT 3 hangs while loading a 13 GB Database

I’m trying to open a big Database of 13 GB, but DT3 would just hang. There is enough RAM. CPU goes upt o 100 %. What could I do, I cannot afford to loose those data.

Thanks for quick help

13 GB not particularly big.

Where in the local file system does the database package reside?

Do you have the latest versions of macOS and DEVONthink running?

Is the disk ok? Try a “repair” with Disk Utility?

If you restore the backup of this database (from system backup or from a DEVONthink Archive) does it work?

  • Also, are you indexing data into the database?
    • If so, from where?

No, I’m not indexing files or folders from outside in this database.

Good to hear, that 13 GB is NOT big for Devon, however it still doesn’t load. It resides on Macintosh HD, MS OS X Ventura, 16 GB, 14" M1 Pro. Disk is OK.
Thanks rmschne and Bluefrog for your quick response, though

Is there a safe way to open the database just in case I don’t have a folder on my radar at the moment?

Or is there a way I could extract / unzip data from the database file and create a new empty database importing the extracted folder.

Are you using any internet-based sync services on where you store the DEVONthink database package? If yes, is the DEVONthink folder set for “offline” access? In any event and as documented, DEVONthink databases should not be placed in sync-based folders as the risk of corruption is probable.

You didn’t give version numbers … both macOS and DEVONthink latest versions?

What happens when you restore the database from your regular system backups (TimeMachine?) or your DEVONthink Archive zips? Do those versions work ok?

When the application is stalled, do a Spotlight search for Activity Monitor . Select our application in the list of processes - it should show “(Not Responding)” and the name in red - and press Command-Option-S to run a sample on it. When the sample window opens, press the Save button and save it to your Desktop. Please start a support ticket and attach this text file. Thanks!