DT 3 Safari Plug-In/Sorter: downloaded PDF not correctly displayd

Hi there,

I tried to download a research paper from this address https://journals.plos.org/plosone/article/file?id=10.1371/journal.pone.0186800&type=printable to the database with the Safari plug in. There is a PDF downloaded, but only one page with a big black rectangle instead of a multi-paged PDF with text and diagrams. I downloaded it with DTPO 2.9 and it worked. (although the title ist not the name of the paper as I would expect).

with DTPO 2.9

DEVONthink 2.9 is very out of date. You should manually update to 2.11.3 from https://www.devontechnologies.com/support/download/legacy

Also, you didn’t say what format you tried to clip to.

I just clipped it as a webarchive, which should work as expected. I got the PDF but the Name came through oddly, and the Filename (shown in the path) is incorrect…

Capturing as PDF yields an incorrect PDF with a still incorrect name. This definitely looks site-specific and Development will have to look into this.

Have you tried this? Print in browser by using “Save PDF to DEVONthink 3” works as long as you can also see the full document in the browser (Safari in my case).

Actually, I meant 2.11.3, sorry.

I tried to clip the PDF to PDF (paginated).

No, as that’s a different mechanism than the Clip to DEVONthink extension is using.

Try clipping it with webarchive. There should still be an issue with the name, but it should be a legitimate PDF.
And again, I think this is a site-specific problem.