DT in Big Sur: Scripts in toolbar going missing

I’ve included some scripts as buttons in my DevonThink toolbar. Each time I start the program, they’ve gone missing. What do I need to do?

Which version of Big Sur do you use? Is this on an Intel or M1 Mac?

macOS Big Sur 11.0.1 and brandnew MacBook Pro 13" with M1

Are you using Icon and Text for the toolbar?

For whatever reason, it now shows my 3 toolbar scripts everytime I load DT again. I swear it wasn’t doing that the 3 or 4 times I loaded DT before (“Ick schwöre!”).

1 Like

Yes. Should I not?

Just logging info for a bug.

@cgrunenberg: I added a toolbar script - beep.

Here but showing a generic document icon instead of a script icon

missing here

That’s the icon for scripts on Big Sur, see Finder’s list view. Anyway, I couldn’t reproduce the issue on the upcoming macOS 11.1. Neither on Intel nor Apple Silicon Macs.

As I said, as soon as I put this up in the forum DT is now starting all the time with the scripts showing up. So for now, issue is non-existent.

And today, for no apparent reason, the icons for my 3 scripts have been gone from the toolbar again. Trying to put them into the toolbar again, they have also gone missing from the toolbar config screen.

I checked and the scripts are still in the script folder / toolbar folder. So DT is apparently not checking that folder. Can you help me here @BLUEFROG?

And for good measure, I’m running macOS 11.1.

After complete restart of MacOS, DT finds the scripts again. Added them to the toolbar again.

And now the scripts are missing again and not shown in toolbar config screen, although they are still in the script folder. This seems to behave very erraticely and is not solved.

What are the scripts called (i.e. what it the complete file name; more specifically, does it contain special characters)? This isn’t happening to me, so I’m just digging in the dark, wondering what the difference between our two setups is (I too am using DT 3.6.1 on macOS 11.1).

Their names are: “Zettel-Link”, “TaggerV5b4” and “MQNLv1b3”, so nothing ordinary here. I really only use the first one most of the time, but that one is important. Of course I can also find it in the script menu, but that is more action than clicking on toolbar icon.

Just want to point out that the issue of missing toolbar scripts still exists. Most of the time, toolbar scripts go missing. Some of the time, you have to restart DT to even be able to add them (for sometimes they are not shown in the toolbar configurator).

Which version of DEVONthink and of Big Sur do you use?

  • DT -> 3.6.1
  • MacOS -> 11.1

And is this an Intel or M1 Mac?

Being asked by the forum software to write in complete sentences, I’m telling you it is a M1 chipset working inside my laptop. I hope the forum software is very happy, indeed.

Just tried this successfully. A screenshot after customizing the toolbar and of the toolbar as soon as the scripts are missing might be useful. In addition, when exactly do the items disappear? After closing & reopening the window, quitting the app or rebooting the computer?