DT Pro Office won't start

Hello, I am new to the Mac. I just purchased a ScanSnap S510M and decided to also purchase DEVONthink Pro Office. I accidently deleted the program and I then had to re-install it. Now everytime I click on the icon I can see it on the dock, but the program does not start. I tried going to the library and deleting DEVONthink also and then repaired the permissions. I then tried to re-install DT Pro Office again, but the same thing happens. I can see the icon on the dock, but when I click on it the program does not open.

Can someone give me any suggestions?



Make certain that you have downloaded the correct application, DT Pro Office, and not DT Pro.

In the Dock, click and hold on the existing application icon, then drag it upwards, outside the Dock area and release it. The icon will vanish.

Now go to the Finder, select the application in the Applications folder and double-click on it. DT Pro Office will open and create a new icon in the Dock. Click and hold on the icon and confirm that you wish it to stay in the Dock.

I assume that you are running under Tiger or Leopard, as the current version of DT Pro Office does not run under Jaguar (OS X 10.3.9).

Sorry, I am running the latest version of Leopard. I checked and I did download the correct application. I clicked and held down the existing icon and attempted to drag it up out of the dock. I can see a white puff of smoke, but when I release the mouse button nothing happens, the con returns to the dock. I also tried to drag the icon from the dock to the trash can and the same thing happens, the icon returns to the dock.

I’m running Leopard, and icons dragged out of the Dock go ‘poof’ and disappear for good. There’s also a click and hold option to remove an icon from the Dock.

Removing the existing icon was recommended because of the the possibility that the newly installed application was at a different location in the Application folder hierarchy than the older, presumably deleted application. If that were the case, the icon would do nothing when clicked; it’s not linked to the newly installed application, and the one it was linked to no longer exists. And double clicking in the Finder on the newly installed application would launch it, producing a second icon the the Dock, which would be confusing.

The test is to now double-click on the DT Pro application in the Finder. It should launch, and the application’s icon should appear in the Dock.

If that doesn’t work, it’s likely that the download was corrupt or incomplete. Download and install again, copying the application from the mounted disk image volume to the Applications folder.

I uninstalled the application and downloaded another copy from the website. I try starting DT Pro Office and again the same thing happen. I was hoping it was going to be a clean install, but when I first started the application is did not go through the initial set up screens. I guess some part of the app was left behind after I uninstalled it.

DT Pro Office was the only app I have downloaded from the website, so there was no chance another DT app was in the applications folder.


Did you try launching the application by double-clicking on the file in the Finder, inside your Applications folder? In other words, don’t keep clicking on that nonfunctional icon in the Dock. It apparently has no connection to your application and should be discarded from the Dock.

To confirm that everything was installed, Launch DT Pro then choose Help > Install Add-ons and confirm that you wish to add them.

I did try launching the application by double-clicking on the file in the finder, but nothing happens, the icon just goes back to the dock. I als followed your suggestion and installed Ad-ons, but I’m still having the same problem.

Len, yes, a new Dock icon was created when you launched the application from the Finder. Unless you click/hold and choose the option to have this icon remain in the Dock, or drag it leftwards in the Dock, it will disappear again when its application is Quit. But if you make it permanent in the Dock, it will now launch the application again after it has been Quit.

You must have succeeded in opening DT Pro if you had access to the application’s Help menu to install the add-ons.

If what I’ve just written here doesn’t correspond to what’s happening on your computer, I would suspect that you have a damaged operating system.

I had no success opening the application. When I double clicked on the icon from the application folder the app did not open, but I noticed that the menu on top of the screen did change to the DT menus and I was able to click on it, even though the application was not open. Do you suggest that I reformat the hard drive and reinstall Leopard?

Sounds like the application was launched with no windows open in the database.

Try File > New Window.

If that doesn’t work, the application was launched with no default database – it’s waiting for the user to create a new database, or to open an existing one. Try File > Open Recent and choose the database that you would like to open when the database is launched. Then choose File > Database Properties and check this as the default database.

Of course, if you haven’t yet created a database, this is the time to doe it.

If launching the application without a database, or with a database with no open windows was the problem, don’t worry about your operating system. :slight_smile:

In the Mac OS, if you see the menu bar for an application, it has been launched successfully.

Ok I think I’m almost there. I was reading the Mac OS X “The Missing Manual” there was a section for problem applications. I opened home folder>library>preference folder> I then dragged the DT .plist to the trash can. According to the book when I re-started DT agin it was going to recreate the file. IT WORKED, I can now open the application.

Just one last thing. I want to make DT Pro Office my default application when I scan documents with my ScanSnap S510M but the Application tab on the settings is grayed out and I can not select it. Any ideas?

And thank you so much for working with this iMac newbie. NT Pro Office is very impressive.

Len, check the ScanSnap Manager settings. There’s something like a quick start option that you should uncheck. Then you will be able to select DT Pro as the target to receive scan output.

Thanks for all your help Bill, that did the trick. :smiley:

Have a great weekend!