DT3 Database won't Open

Hi there,

DT3 was Indexing a folder, and it crashed. I’ve since rebooted the computer, and attempted to open the database that contained the folder that was indexing, but it won’t open. I don’t receive an error message other than that it may be in use, and I’m asked if I want to proceed or cancel. When I choose Proceed, nothing happens. Nothing is logged other than “Index” - successfully verified.

Because I can’t open the database, I can’t Verify & Repair, nor can I Restore from Backup, or Rebuild my Database. My only option it appears is to Recover or Manually Rebuild. I do have backups in my CrashPlan application, but is this the only solution?


Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - devon-technologies.com - thanks!

To fix the issue please try this:

  1. Select the database in the Finder
  2. Choose Show Package Contents in the contextual menu
  3. Remove the file DEVONthink.lock

Are you able to open the database afterwards?

@cgrunenberg, no. After removing the DEVONthink.lock file within the Package, I’m still not able to open the database. Still, nothing happens when I attempt to open it.

And after zipping and unzipping the database and trying to open the unzipped one? This might sound weird but sometimes this fixes some weird file locking issues of the system. Finally, did you send me the logs as suggested?

After you press Proceed, did you select File > New Window and see if you can open a new window for the database?

Hey Jim,

Press Proceed where? I haven’t seen an option to Proceed or File -> New Window. Where and when should I see that?

@cgrunenberg, To be sure, you’re suggesting that I simply zip and unzip the database? I can do that.

Does it make any difference that this particular database is stored in a sparse image?

This shouldn’t make a difference but you could copy it to the desktop first and try to open the copy. In addition, is there still enough disk space available on the sparse image?

Above you said…

When I choose Proceed, nothing happens.


Damn, damn, damn! The sparse drive was full! That’s such a rookie mistake on my part, for not checking that, first thing! Moving the database from the sparse drive to the hard drive, allowed the database to open.

However, when I attempt to Empty Trash and delete the Indexed files by pressing Database Only, DT3 instantly crashes. I ran Verify & Repair, it found errors and attempted to fix them, but that failed.

I assume that I should Rebuild Database?

The missing items are logged to Windows > Log, via the contextual menu you can either trash these items or reveal them.

@BLUEFROG-Sorry Jim, I’m just waking up and didn’t remember mentioning that. I was only given the option to Proceed or Cancel. Are you suggesting that after pressing Proceed that I should have opened a new window?

Chris, which contextual menu are you referring to? I haven’t seen any options to trash or reveal.

The one in the Windows > Log panel. After using File > Verify & Repair Database… all missing items should be logged there.

Right clicking on the items in the Log, gives me the option to Reveal or Trash.

Trashing them and emptying the trash would fix the issue. But you might want to use Reveal first to check what exactly is missing.

As I scrolled through them, the files all appear to be items that were in the Trash. I did an Empty Trash, and then Verify & Repair and all seems to back to normal.

Instead of using an encrypted Sparseimage, is it possible to convert this database to an Encrypted Database? Or is it better to just delete the old Sparseimage, and make a larger one?

Encrypted databases are actually sparse images containing .dtBase2 databases, only the extension is different to ensure that double-clicking automatically opens DEVONthink 3. Important is therefore only that the maximum size will be sufficient.

Got it. I’ll just create a larger Sparseimage.

Thanks you guys for your awesomeness! Panic: Done. :crazy_face: