DT3 - Problem Restoring Purchase

Purchase a one time upgrade on the iPad. DT3 opens fine on tow iPads and recognizes the upgrade. However, when I press Retry/Restore on the iPhone, it does not recognize it. Nothing happens.

Already tried restarting and re-downloading DT3. iOS 14.4

Removed both DT2 and DT3 from one of the iPads. Re-downloaded DT3 and the same problem occurs. It does not recognize upgrade purchase.

Why aren’t you taking the option for the free six months?

It is an app I will use anyway so why not purchase the upgrade?

1 Like

I did the same. I did not want to end up having to subscribe later on. And if I wanted to use it now, why not pay now instead of later?

The only way to make it work so far is to download DT2 first and then open DT3.

Seems like a bug.

The screencap you posted shows the options when both version 2 and 3 are installed.

Right but I did make the purchase, which does not reflect on other devices.

I’m seeing the same thing: Installed DTTG3 on iPad and chose the one-time payment (upgrade). Then downloaded DTTG3 on iPhone and can’t restore my purchases there, only go for the six month trial period (as per the screenshot in the first post).

Now are you saying that I should remove DTTG2 first so that I can restore the purchases for DTTG3?

You need to download DTTG2 first and the open DTTG3.

But DTTG 2 is already installed on the device anyway. Should i remove it and DTTG 3 and then re-install them both again? I find that a bit confusing.

If you have DT2 installed, open DT3. It should recognize the upgrade. Worked for me.


Recognize the upgrade? Don’t know what that means. I have purchased the unlimited version on iPad and should be able to use that on iPhone, too. However, everything but the “try for free for six months” option is grayed out, as well as the possibility to restore my purchases.

download DTTG 2 on your iPhone and then DTTG 3 will recognise you have purchased the one time upgrade and then you can go ahead and delete DTTG 2 again on your iPhone. Seems to be a bug so currently you need to have DTTG 2 installed on each device you want to use just so DTTG 3 on so the upgrade works correctly.
After DTTG 3 has detected the upgrade, just delete DTTG 2


As I said:

But in the meantime I saw that it did recognize the upgrade. The information is just not very clear. Or I’m too dumb. Anyway, thanks for your help.

I don’t think you can (re)download DTTG2. I downloaded DTTG3 on my iPad, and paid for the $20 upgrade. I had some sync issues; so, I deleted both DTTG3 and DTTG2. I re-downloaded the former, but the app won’t let me past the payment screen, and the only options available are to repurchase as a full upgrade, or on a monthly or yearly subscription. And I cannot find DTTG2 in the app store, to test your proposed fix. Note: the purchase upgrade is recognized on my iphone, which has both DTTG2 and DTTG3.

So, a warning for anyone downloading the DTTG3, do not delete DTTG2 at this time, as this seems to be a bug, and a fairly serious one at that. I’ve paid for a product that I can’t as of now use.

Also, to address BLUEFROGS’ remark above, I (and I suspect others) have already paid for the app because Devonthink is essential to my work, and there is really no question of whether I’ll be upgrading. If I know $20 is the cheapest option, why wouldn’t I simply take the plunge?

sorry, thought you meant you already had it installed on your iPad, not your iPhone. I misunderstood, glad you got it sorted in the end

You can download DTTG 2 after its been deleted, tap on your profile in the App Store and select purchases, you can search it from there and download it again

1 Like

I am seeing something similar. I was able to download and upgrade on my iPad fine so I deleted DTTG2 from my phone and just installed DTTG3 there but when I get to the “Retry / Restore” option when I click nothing happens. I tried removing the app and restarting but that did not resolve the issue.

If your options look like the picture at the start of this thread, you’re fine. I think.

Thank you very much for your help. That worked like a charm.