DT3: removing inheritance of Tags is a nightmare for me

Dear Team,

I’ve a lot of Groups and Subgroups within my DT databases including Tags for those Groups. So it’s easy for me to look for particular files by just do a query e. g. “all files with Tag=abc and Tag=2019” regardless where they are. So, I’ve the best of “both worlds”:
(1) Groups and Subgroups to organize based on hierarchy as well as
(2) Tags to organize based on content
I’ve many Smart Groups to group files based on Tags - and the Tags where inherited through Groups and Subgroups automatically - very nice. THAT feature to use DT. And it’s so cool that DT2Go recognizes this as well, new files within a group are automatically tagged…

Is there any chance to get this feature back to V3? or any smart hint how to handle this workflow?

Thank you.
Klaus

2 Likes

This is actually intentional to make the tighter filesystem integration of indexed items compatible to the Finder (which doesn’t inherit folder tags). One alternative might be to disable the option to exclude groups from tagging (see File > Database Properties…).

1 Like

Strange - the smart groups still find all my files!?
Example:

  • I’ve a group “Bla” with a Tag “Apple”
  • All files within that group are without the tag “Apple”. I’ve checked this. OK
  • Now I add a Tag “Opty” to one of these files. OK.
  • Now I create a smart group within that group looking for all files with “Tag=Apple & Tag=Opty”. And that one file is shown within that smart group! (I expected zero output due to the not inherited Tag Apple)

Nice - but I dont understand why…any hint?

if I take a look to the Tags of that DB then I see the Tag “Apple” with all the files - the files themselves are not carrying that Tag (Info Window doesn’t show the Tag) but they belong to it somehow. I give it up to understand this :slight_smile: the result is nice, I can continue using my smart groups. A bit strange, because I get the result but none of the files showing the Tag.

1 Like

This happened to me too. I tagged a group “ignore” to avoid it being labeled, and it meant all the documents were also tagged ignore. But I couldn’t actually see the tag for each document, nor would it remove with a smart rule. To remove it in the document, I had to remove the group’s ignore tagged. Even though the docs aren’t supposed to inherit that tag from what I understand.

This seems like a bug.

1 Like

If nothing else, this seems like unexpected behavior, as if the tag is propagating but invisible.

Parent Folder with tag parentTag.
Smart group:


…yields:

I’m sure @cgrunenberg will have some insight into this.

hopefully the propagating remains…even if invisible :slight_smile: and also in DT2Go…helps a lot to see all my „automatically“ assigned Tags there

This seems to be a bug.

@Airestocky don’t mind the propagating but automatic invisible tags are kind of a nightmare. we should at least KNOW the tag exists. i like the idea of being able to hide tags we don’t want to see, i want to make that choice actively.

@cgrunenberg Is there a resolution of this issue?. I notice the same behaviour in the current version of DT3.

This can be enabled in File > Database Properties.