DT3b2 not performing OCR automatically

I’m using beta 2 and a ScanSnap ix500. ScanSnap Home (SSH) is set to pass the document to DT. DT is set to OCR incoming scans, move to trash and enter metadata after OCR. However, OCR is (still) not triggered automatically when SSH passes the document to DT, where it appears in the global inbox - this was (as I understand it) a known bug in beta 1, but my understanding was it was to work in beta 2. What am I doing wrong?

Apologies: my previous post referred erroneously to beta 3…which doesn’t exist! Sorry! (That’s what comes of beta testing two software applications at the same time.)


Is SSH’s Send to set to DEVONthink or are you setting the Output in SSH to the Global Inbox?

I think the smart rule somehow always move the OCRed file into global inbox.
I see the same issue without interacting with SSH: DT3b2 Smart rule issue with OCR

The OP didn’t mention smart rules. Just ScanSnap Home input as far as I read.

Sorry. I could be naive in assuming that same sort of process/script is shared between the ocr arrangement in smart rule vs the handling of scanned file from SSH.

Development would have to comment on this.

Here’s the OP back; so: I’m not using any smart rules. @BLUEFROG Jim, SSH is set to “Send to” DT (SSH, Scan Settings, Application Send to DEVONThink) - actually I don’t even know how I would set the Output in SSH to the Global Inbox (I followed the same procedure as I did for DT2, adding DT as an Application in SSH Preferences and then choosing that Application whilst creating a new Scan Profile in the Scan Settings); am I explaining myself in a clear fashion, or would screenshots be helpful?

No, that sounds about right. Hmm… Not seeing an issue here with beta2 on macOS 10.14.5.

Hold the Option key and choose Help > Report bug to start a support ticket. And please include ~/Library/Application Support/DEVONthink 3/SPScannerPlugin.rawnsloggerdata as it might have some useful data for Development. Thanks!

I have just done the following: restarted Mac (didn’t help), in DT preferences changed “to searchable PDF” to “no action”, removed the checks for “Move to trash” and “Enter metadata after text recognition”, restarted DT, scanned a document, in DT preferences changed “no action” to “to searchable PDF”, checked “Move to trash” and “Enter metadata after text recognition”, restarted DT, scanned a document - now works as it should.

I have refrained from sending the Bug Report; but maybe this post will help anybody else who experiences the same problem. And if not: it was nice chatting to you all, thanks for your help!

1 Like

Interesting! Thanks for the follow-up. It will be interesting to see if the procedure bears out with anyone else who might run into this issue.

Just to add that I have the same experience as the OP. My ScanSnap output was put directly into the global inbox without OCR. I followed the OP’s steps exactly, and now it works just as it used to with DT2.

As a bit of observation, for what it’s worth, when it wasn’t working, the file was listed in the log and the info column read “No text”, the original document was not deleted even though “Move to Trash” was checked, and the file was put directly into the global inbox.

After the fix, no entry was put in the log, the original document was deleted afterward, and the popup to name the output file appeared. It’s as though the OCR section of the preferences was ignored until the changes nudged it into action.


et al:
The OCR bug should be addressed in the next beta release. Thanks for your patience and understanding.

1 Like

It was easy enough to solve on an individual basis - it doesn’t require too much user patience or understanding :wink: Thanks for apologising for your beta software not being quite perfect yet. It’s pretty damn good though :wink:

Agreed, it is a good (and fun!) beta for sure. :slight_smile:
Some may think I’m an old curmudgeon but I always try to be careful with peoples’ data :joy: :stuck_out_tongue:

I can confirm that @Blanc’s workaround works for me as well.


An additional question:
The scanner output must not be stored in the Global inbox, but in DT3 directly. With the old SnapScan Manager and ScanSnap S1500M I cannot activate the DT3 as output target. Does this mean that I can no longer use the direct scan with my old appreciated equipment?

Hi Roland! I’m a little surprised; I don’t have the legacy SSM on any devices any more, but as I remember it, you could create profiles with an app of your choice as target. Assuming you haven’t done so, that is what you would need to do - generic instructions can be found e.g. here: https://scansnapworld.com/make-scanning-profile-using-scansnap-manager-mac/

I seem to remember you will have to add DT as an application before creating the profiles, but that too was relatively self-explanatory (here are instructions for doing this on a PC, sorry, can’t find any for Mac: https://scansnapworld.com/how-do-i-add-an-application-to-scansnap-manager-pc-2/)

If you’ve already done all this, please accept my apologies; if this is all news to you and I can maybe provide more help, let me know.

If ScanSnap Manager is working on your version of macOS, there shouldn’t be any reason why you can’t send the scanned files to DT3. Do have some screenshots of how you have DT3 configured in ScanSnap Manager and the scan settings.

Hi Blanc,
first of all I have made an profile for DT 3, that was the easy way to do. The problem is to select the place where the scan result may be stored. I can use the inbox folder, but this is not the solution for DT3.