DT3b3 Database maintenance


Although it’s very reassuring that DT makes sure databases don’t get corrupted, I do find that since beta 3 came out there is a lot of “Tidying” going on in Activity Monitor, sometimes for very long periods of time. This has the effect of long pauses before actually quitting the app after pressing Cmd+Q if you’ve set the preferences to sync on quit (even if the actual data to be synced is very small).

For example, I have two databases, “Main” and “Other”. Just now I highlighted a few lines in a couple of PDF files (2 megabytes each, single page) in the “Other” database. The files were synced and then I had “Tidying 1 of 25 items” for around a minute, then “2 of 25” for another minute. I got tired of it so I press Cmd+Q again, which caused DT to crash to the desktop.

After relaunching, I tried to perform a “Verify Location” on my sync store but the option is greyed out. There’s a spinning “working” icon on the Inbox (in Sync Preferences) which alternates with my “Main” database, going back to Inbox, and then gets stuck on “Main” again. I can’t “Verifiy and Repair” this database because that option is greyed out too, which isn’t very reassuring. The “Other” database (in the same sync store) is verified normally and is OK.

If I then quit (press Cmd+Q twice, no crash) and restart, reloading the two databases, I notice that now “Other” is spinning in Sync Preferences and I can therefore Verify and Repair “Main” (which is OK). However, I still can’t do a “Verify” on the sync store because “Other” is spinning.

In short, it’s difficult to understand what DT is doing at any one time and messages in the Activity window are not always helpful.

BTW the sync store is on a custom WebDAV server which has been working almost flawlessly for more than a year since DT2.

Thanks for your help.

Crashes should be reported in our support ticket system.
Hold the Option key and choose Help > Report bug to start a support ticket.

OK will do, but like I wrote this is not a crash issue. DT is not crashing now but I still can’t verify the location or quit without waiting for several minutes for sync tidying to finish (even without any modifications).

That is correct. You cannot do maintenance routines while sync is going on. That is by design and has been in place for some time.

Well, this is starting to become frustrating because I know that and this is what I’m trying to report here. This “tidying” business has recently become extremely long and providing very little information to the user, with no major changes happening to the databases.

For example, after last launching DT, the Preferences window shows the app cycling through 3 databases twice, taking up to two minutes each, without me doing anything except looking at the interface. I have not modified any database but for some reason sync is cycling between all of them, preventing me from doing a “Quick Verify”.


(The animated circle icon isn’t captured for some reason)

The only feedback I’m getting is a blank blue line with no text which isn’t moving and stays put for a couple of minutes.


When it finally stops I ran a “Verify Location Quickly” and didn’t get any message (either good or bad). The app just displayed this activity:

It’s been displaying this since I started writing this post, about 8 minutes ago. It hasn’t moved.

Nothing has changed with regards to my server as far as I can tell. I can download stuff from it using DT on iOS with no problems.

I hope this makes the issue clearer.

Thank you.

EDIT: Cmd+Q of course doesn’t quit the app now, because it’s still stuck on “downloading 2 of 3” above. I have to Cmd+Q a second time to force it to quit (although it didn’t crash this time).

EDIT: Cmd+Q of course doesn’t quit the app now, because it’s still stuck on “downloading 2 of 3” above. I have to Cmd+Q a second time to force it to quit (although it didn’t crash this time).

This behavior has actually been in place for a long time, even back to DEVONthink 2.x.

Did you start a support ticket so we have access to the logs?