DT3b4 : Finder Comments


Text added to a PDF in the Inspector’s “Finder Comments” section is only partly saved when switching to another document, or not saved at all.


It’s not saved in DEVONthink or not in the Finder? The Finder’s comments are actually limited to 256 characters (or bytes?) as far as I remember, DEVONthink’s comments aren’t limited.

It’s not saved in DT. I didn’t even look at the Finder, I just switched to another document and came back immediately. The comments I added were just a couple of names, maybe 30 characters max.

What kind of item was selected? Did you change anything else in the Annotations & Reminders inspector?

It was “PDF+Text” and I didn’t touch anything else except doing a single search beforehand in the Search pane of the Inspector.

Are you able to reproduce this?

I tried it three times before posting just to make sure, will try again when I get home.

I confirm I too do not see finder comments in the inspector after indexing items that have comments in their properties. I see the files and folders (Groups), but not their comments. The length of the comment is max 40 characters.

@cgrunenberg: I confirmed this behavior here with the internal build.

Adding a Finder Comment in DEVONthink replaces the comment in the Finder.

Also, this affects imports as well as indexing.

Ok thanks! Clear

Did you add this comment right before indexing? In that case it’s possible that the Finder did not yet save the comment to its store. However, I tried to reproduce this and a simple test was indeed successful.

I just tried it with a file I added comments to an hour ago. No Finder comments imported.

In which folder is the file located?

A folder in my Downloads folder.

Weird. I used the same folder :slight_smile: And after logging out and in again?

Yes, the problem still happens after a machine reboot.

Could you send me a zipped copy of the folder? This should include the hidden .DS_Store file of the Finder which is used by DEVONthink.