DT3b4 : unsaved changes in PDF


First time ever in DT: browsing a 10 page PDF, highlighting and saving (Command+S) as I go along. Last couple of highlights weren’t saved. When trying to close the document I got the message “Save changes ?” Clicking “Save” didn’t do anything. Really, anything, as if the button click action wasn’t connected to any code (except reacting to the click with a color change). I tried this twice (using “Cancel” as the action between the tests). I finally had to click “Don’t Save”, do the needed highlights again, and save manually (which worked fine). There’s clearly an issue with the save dialog code.


Please choose Help > Report Bug while pressing the Alt modifier key and send the logs to cgrunenberg - at - devon-technologies.com - thanks!

I also have an issue when removing and inserting pages using the small previews: when closing the window DT asks to save changes, after pressing button “save” nothing happens, no saves, window keeps open - “discard changes” closes window at least…

Same thing just happened here >> lost pages of highlights/annotations on a PDF. :tired_face:

Have posted the log/bug report through to you!

EDIT:>> A restart of DT3, appears to have fixed the issue. But probably something to have a look at!

The next release will fix this. In the meantime saving before closing a PDF window should help.

Saving before closing definitely does not help. I carefully kept saving after each PDF annotation and then couldn’t close the document. Just lost 45 minutes of work. Yes, I know it’s a beta.

1 Like

Same here, unfortunately.

Not complaining - I accept the risks - just clarifying that the Save dialogue doesn’t appear to be doing anything since(?) the update to Beta3v4.