DT3beta Help Unavailable from Dialogs

Clicking on the question-mark-inside-circle help icon often seen in dialog windows (e.g., DT3 > Preferences…) results in the display of a macOS Mac Help dialog with the message, “The selected content is currently unavailable”. I’ve seen this in all DT3 beta versions (currently up to DT3b4). Outside dialogs, DEVONthink Beta Help is available via Help > DEVONthink 3 Help.

In an earlier post mentioning this message the fix was to allow macOS time to index the help contents. However given the amount of time [weeks] that has elapsed since I began running DT3beta, that wouldn’t seem to be the issue here.

Just sharing my experience: If you have ever opened the package content or have indexed the internal help file into DT3 in earlier beta, some files/filenames might have altered by you accidentally. I have encountered the same issue re access to help due to the above-mentioned actions.
A full uninstallation and reinstallation of DT3 solved my issues (page 6 of the manual re "INSTALLING, UPDATING, UNINSTALLING*).

I had the same problem. But it worked for me after restarting

I uninstalled DT3 from my main user account, following the instructions on page 6 of the manual. I then created a new macOS user account, downloaded a fresh DT3b5, and installed it in the new account. The problem remains: DEVONthink help is unavailable from dialog windows. As stated earlier, it is accessible via Help > DEVONthink 3 Help.

Interestingly, I went back to my main account, and ran DTPO (v2.11.3), and Help doesn’t display from its’ dialog windows either, and causes the same macOS Help message, “The selected content is currently unavailable.”