DT3's 'Clutter Free' Clip (as PDF) from Safari Option Not Working

If I try to add a web page as a single-page PDF, using the ‘clutter free’ option, either from (1) Safari’s ‘share’ button, or from (2) the Safari extension, or from (3) the menubar ‘sorter’, there is a long delay (minutes) and finally the thing gets added to DT3’s inbox - as a bookmark, NOT as the PDF as I wanted.

Try this link in Safari:


• Using Safari’s ‘share’ button (“Add to DEVONthink 3”):

  • With clutter-free option: doesn’t save a PDF, but a bookmark. Throughout the waiting time the ‘activity window’ tells me “Downloading Web Pages”. One minute 52 seconds later, the log window pops up and tells me that a bookmark has been saved. And that’s what has been saved, a “web internet location”, or a bookmark - not the PDF I wanted.
  • Without the ‘clutter-free’ option: sometimes a blank PDF, but more often than not, it works, virtually instantly; a good PDF.

• Using the Safari extension:

  • With clutter-free option: same thing as when using Safari’s ‘share’ button: a bookmark, not a PDF, after a long wait.
  • Without clutter-free: a PDF, quickly, BUT with a big black rectangle obscuring the top of the document.

• Using the ‘sorter’ menu item (the rightmost button), “Capture content from… Safari”:

  • With clutter-free option: same thing as when using Safari’s ‘share’ button: a bookmark, not a PDF after a long wait.
  • Without the ‘clutter-free’ option: It works, virtually instantly; a good PDF.

This same pattern occurs with virtually every web oage I try with the ‘clutter-free’ option, which therefore doesn’t seem to work. :neutral_face:

A bookmark is captured as a fallback when the extension encounters a problem. Reboot the machine and see if the issue persists.

It is working for me:

Hmm. Strange. On my other Mac (MacBook Pro), I don’t encounter the problem, but even after rebooting this iMac, the problem persists. I can’t think why.

Perhaps you have connection issues. This thing needs go to Devontechnoligies server to be processed.

Like what sort of connection issues? The problematic iMac is hard-wired to the network via ethernet, while the problem-free MacBook Pro is connecting via Wi-Fi. (Plus, I didn’t know that the data was sent to DEVONTech…)

I don’t know what could be your network issue, but if it works in wifi and don’t in wired, perhaps you can disconnect the cable of your iMac and use its wifi to check if works. Then you are sure your cabled network has an issue.

AFAIK, the URL is sent to Devon servers, and they do the scrapping and returns the result.

No, if I switch the iMac connection to Wi-Fi, the problem is still there.

I’m out of ideas. Perhaps cleaning Safari cache, or try from a freshly created user account.

Hold the Option key and choose Help > Report bug to start a support ticket so we can look at the logs.

In the last few days, I am also experiencing this issue in Brave, either using the clip extension or bookmarklets. Clipping a text selection works fine. Clipping to PDF (with or without the clutter option) returns a bookmark

  • Does this persist after rebooting the machine?
  • What version of macOS are you running?

Yes it does. I’m on Mojave

What URL?

Any url actually. I just tried again with Devonthinks latest blogpost. I downloaded the bookmarklets PDF (Paginated) and also tried with Clip to Devonthink Extension. Still broken: keeps returning a .webloc file

Hello, This is a very important function for me and I confirm that it has stopped working sometime in the past weeks. I only get a webloc and if I disconnect my machine from the net, I cannot see anything behind this webloc.
I meet this problem on a MacBook running OSX 10.14.6 and DTP 3.5.2 and both with DTP browser, Safari and Firefox, with or without the clutter-free option, with both PDF and Web archive captures.

I really hope we will get a solution for this.

Welcome @myildi

Did you reboot your machine and see if the problem persists?

1 Like

Thank you for this suggestion. I have rebooted the machine and also deactivated and reactivated the DT plugin in Firefox and now it is able to save Web archive again.
Good to see this, I was having this problem for some time :frowning:

Do you know why DTP loses this ability sometime?

THis morning I have had to deactivate and reactivate again the Plugin because it stopped working again.

I am having this same problem with the web clipper on Chrome. I found that restarting DEVONthink allows me to capture successfully from the URL that failed, however within a few minutes the problem recurs.