DTP 2.8.4 AppleScripts Failed to Install

When I go to DEVONthink Pro > Install add-Ons, and check all of the script related boxes, and then click INSTALL, DTP fails to install the AppleScripts. The Log simply states “Failed”.

I think I know the reason, but I’m not sure what’s the best fix:
About a year ago I replaced the Scripts folder in the ~/Library folder with an alias of the Scripts folder which points to a folder within my Dropbox setup. I did this in order to have only one set of Applescripts to maintain across multiple Macs, and FastScripts does not support folder redirect using symbolic link. So I had to use a folder alias.

All seems to work very will with the alias, including the Apple Scripts menu.

I don’t know, but I’m guessing that DTP does not support redirect via alias, correct?

So, short of restoring the Scripts folder, is there a way I can get the DTP Applescripts installed somewhere else (then I can move them)? Can they be downloaded?

TIA for you help and ideas.

Undo the aliases, let DEVONthink install the scripts to the proper locations, then redo your aliasing scheme if you must. As long as your FastScripts config is broken, you’ll need to do this every time you upgrade DEVONthink with a new release.

I’ve never had a problem with FastScripts and symlinks. My personal script library is symed from Dropbox to ~/Library/Scripts and FastScripts indexes this without any problems. Your problem is possibly not due to the symlink.

Thanks for the very quick, and helpful reply korm.
Maybe it works for you because you are “over there”. :laughing:

I’ll try symlinks again. If it still doesn’t work, I’ll go with your suggestion.

BTW, here’s a thread from the FastScripts forum acknowledging symlinks doesn’t work. But that was in March, maybe they’ve fixed it since then.
Support symlinks for Scripts folder

In my case the symd folder is a subfolder of Scripts.

BTW – DEVONthink installs scripts in ~/Library/Application Support/DEVONthink Pro 2, ~/Library/Scripts/Folder Action Scripts, and ~Library/Scripts/Applications/…. The bulk of the scripts are installed in the first folder mentioned – which has nothing to do with your situation. This is why I think there’s something broken in your configuration.

That’s the key difference between our use of symlinks.

I tried symlinks again with the Scripts folder, and FastScripts did not reconginze anything in the target folder – just as before.

But, I found a solution that works for both DTP and FastScripts:

  • Create Symlink for the Scripts folder in the Users ~Library folder to a “Scripts” folder in Dropbox
  • Add alias links to my Dropbox folders for Application scripts to the machine Library folder:
    /Library/Scripts/Applications
  • For example, I added an alias to the above folder for my Evernote script folder in Dropbox

So DTP now properly installs all AppleScripts, and FastScripts can see the scripts I need.