DTP3 + Apple Mail archiving

I just upgraded to DTP3 from 2 and decided I’d try to give mail archiving a try in a separate database as a way to circumvent the horrific searching experience I’ve had with Apple Mail. I’m currently on Mojave (10.14.6) with no plans to upgrade (downgrade?) to Catalina in the near future.

I have two separate e-mail accounts in Apple Mail. I’d like to archive the Archive folder of each e-mail account. I managed to get the first one archived to the new database I created but no matter what I do I can’t seem to get the second account’s Archive folder to archive.

What I’m doing: After the Apple Mail dropdown refreshes I click on the Archive folder, at which point I get a spinning pinwheel icon thing (not the beach ball, the other one) within the main window. Nothing ever shows up in that window and the Archive folder goes from having a number next to it, the number of emails in the folder, to having no number next to it. Nothing ever shows up in the main window other than the pinwheel. The “Archive Mailbox” button in the bottom right corner of the window does nothing, and nothing shows up in the log.

What I’ve tried:

  1. Refreshing. The only thing this does is bring back the email count next to the folder.

  2. Refreshing + right-click Archive Mailbox instead of left clicking the folder and then clicking Archive Mailbox in the bottom right corner.

  3. Followed the instructions here, specifically deleting the DEVONthink.mailbundle and re-installing the plug-in.

Thus far nothing has worked. Any help is appreciated.


  • How many emails are you talking about in each mailbox?
  • Are the mailboxes broken down into sub-mailboxes?
  1. The one I successfully backed up has ~5,000 e-mails. The one I am having trouble backing up has ~55,000 e-mails.
  2. There are no sub-mailboxes. These are just the archive folders of each of the two accounts.

Try this…
Open /Applications/Utilities/Terminal.app and enter each line as a separate command…

defaults write com.devon-technologies.think3 MailImport.FetchTimeout -float 300
defaults write com.devon-technologies.think3 MailImport.Timeout -float 300

…while DEVONthink isn’t running to increase the timeout to 5 minutes.

The behavior is unchanged.

Hold the Option key and choose Help > Report bug to start a support ticket.

When the application is stalled, do a Spotlight search for Activity Monitor . Select our application in the list of processes - it should show “(Not Responding)” and the name in red - and press Command-Option-S to run a sample on it. When the sample window opens, press the Save button and save it to your Desktop. Please attach this text file to your Support Ticket so we can inspect it.


Done! The only thing I couldn’t do is the last step. The application never actually becomes unresponsive in Activity Monitor. I’ve still sent a sample taken during the pinwheel portion, though.

Things I learned/forgot to include while reporting this bug:

  1. My Apple Mail actually does become unresponsive during the process.
  2. The e-mail importer pops up after I click “Archive Mailbox” and, for the first time, is now presenting an expected time of completion (39 minutes).

I’ll send this along in an additional e-mail.