DTPO 2.10 breaks "move" and "replicate" scripts?

Installed version 2.10 but using the scripts Move__Cmd-Ctrl-M.scpt or Replicate__Cmd-Ctrl-R.scpt no longer work, producing instead the error “Can’t get «class DTlo» of missing value.” Tried uninstalling then reinstalling from Devon’s web interface but no difference.

Do these scripts need to be updated, or can anyone offer help otherwise? Keyboard control of the “move” and “replicate” commands is pretty important…

Mark Chaffin

There’s a bug. We are looking into it. Bear in mind, there are many other ways to get files into specific locations in the interim.

Since 2.10, I’m having trouble calling up the group selector. Even with a simple script like this:

tell application id "DNtp"
	set theDB to open database "~/DEVONthink/Reference.dtBase2"
	set theTest to display group selector "Make a selection"
end tell

I get a ‘missing value’ message and the selector doesn’t display. Is this related to the bug?


  • Leon

That IS the bug. :smiley:

Count me in… I have the same “missing value” bug that I use in my own script, including an important one that is run in m FileMaker database to link the current object to a DEVONthink group.
Until this bug is solved, I have to unlock the field and manually paste the ID contained the link obtained with “Copy link” in DT. Please let us know when the bug fix is planned for release.
Best regards,

It was already fixed in the 2.10.1 release. You need to update your software.

Thank you Jim. For some reason the DTPO installation on my iMac never warns me of updates, opposite to my MacBook Pro.