DTPO 2.8.8 Name field compressed

Is it a deliberate UI decision in 2.8.8 to squash up the letters of names that are too long to fit in the name column, such that the individual letters overlap?


It appears to be a change in UI behaviour. A clever change I admit, but one that causes problems with some font faces.

This is the list view font (Preferences -> General) set to Lucida Grande 12 pt and with the width of the name column reduced:


This is with the width of the name column extended:


It works better with some fonts than others and I have seen examples of overlapping with some fonts. Perhaps there is a hidden preference to turn the behaviour off.

I have found Helvetica works quite nicely with the compressed view.

(There also appears to be a bug in the font changer. If you search for a font, Its not possible to select the new font immediately after the search. You have to close the font changer box and reopen it from (Preferences -> General->List view font -> Select)

Its a clever interim solution but ultimately I would prefer a solution like this:
[url]Suggestion for change in UI behaviour of columns]


Actually it’s not a change of DEVONthink but version 2.8.8 was compiled using both the latest SDK and the latest version of Xcode and this can sometimes change the behavior of OS X, especially of the latest version of OS X. At least the system font and Helvetica should work as expected.

Thanks for your answer Christian.

Is there any way to choose San Francisco (which I understand is the default system font) as the list view font? San Francisco doesn’t show up in my font picker nor in font book.


Sorry to say: In my view, the condensed fonts (even Helvetica) look very ugly - and they are hard to read as well. So I’d be grateful if someone found a way to turn this behavior off.

Thanks Christian. Helvetica works OK but doesn’t look great. I can’t see any way of selecting the system font in General/Preferences. Ironically, Comic Sans works OK too.

Edit: it looks like I can get the system font by choosing a foreign system font like Osaka in Preferences/General

Nice catch. The ‘Osaka’ trick works for me too and looks better than Helvetica with no compression. Curiously selecting Osaka for the List view Font also changes the displayed column view font although not the name of the font in the General-> Preferences.

Would still like to have my Lucida Grande back though :frowning:


Osaka made it for me! Thanks all your geniuses out there.

I actually started a support ticket before I saw this on the forum.

Works fine now but unread messages in RSS is no longer bold…

Looks perfect to me.

You can return to the system list font by executing:

defaults delete com.devon-technologies.thinkpro2 ListFontName
defaults delete com.devon-technologies.thinkpro2 ListPointSize

In the terminal. I am not aware of a way to get Apple’s font picker to do it. Maybe an enhancement would be to add a small X in the control displaying the font name to clear it (similar to the one in the search box).

That Terminal command was great!

Now I even got my unread RSS bold again!

LOVE this forum. So much knowledge for us newbies to take part of!

THANKS ! :smiley:

The Terminal command works in changing the List View Font, but (for me) it has no effect on the Column View Font. After executing the command I get System Font Regular 11 for the List View Font, which is fine, and I can change the size in the font picker. However, the Column View Font remains unchanged. How can I revert that font to the system font (apart from applying the fudge of using Osaka)?

defaults delete com.devon-technologies.thinkpro2 ColumnFontName
defaults delete com.devon-technologies.thinkpro2 ColumnPointSize


Many thanks Frederiko - I should have thought of that!

Thans Frederiko, that changed the columns as well!

Funny that DevonThink makes a great update, Apple makes it look funny.

I have had the same problem with some apps in iOS. Developer does their work according to Apples rules, then Apple CHANGES the rules when the developer have submitted their app for approval. As a user we have nu clue what is happening behind the scenes and maybe that is good sometimes.

After all I remember when I had to work 2 years on a PC because of my work and I started to collect error codes but gave up. After all what we have is superior - both DevonThink AND Apple.

That did the trick; thank you! And now it’s set to this after adjusting the List View Font size:

defaults read com.devon-technologies.thinkpro2 ListFontName

Any method of resetting List/Column View Font values to the System Font defaults from the GUI would be appreciated.

I just submitted a feature request for this. Others who are interested should also submit a feature request so they can gauge the interest.

I am seeing the same problem in DevonNote. The Terminal commands seem to be designed for DevonThink. This list font problem is driving me crazy, so does anyone know if there is a way to “fix” DN, too? Thank you for any help you can provide!

It’s the same command but using com.devon-technologies.note2