DTPO 2 public beta 3 error messages

I have just downloaded public beta 3 and tried to install. However, the thing won’t work. Here’s what’s happening -

When I drag the icon to the application folder I get the following message:

The operation cannot be completed because the item “DEVONthink Sender” is in use.

When I click the ok button another message appears -

“The operation cannot be completed because the item “MacOS” is in use.

Can you tell me how to get round this or fix the problem? :frowning:

couldn’t reproduce your error.
This time all (!?) went fine, AFAIK.
Download pb3. Replace old pb2 by pb3. Start DT; download additional 91MB from Abby and … tataaaa … import old Dbase with all pdfs, correctly named.
So far this should have been the firs public beta … shouldn’t it?

Maybe you should delete all pb2 files first (incl. all DT associated files like prefs, helpers etc) and start again.

Make certain that the DEVONthink application has been Quit.

Delete the older DEVONthink application from your Applications folder.

Install the new DEVONthink application into your Applications folder. That should do it.

I should have thought of this. I fixed it by clicking on the wee DEVONthink Sender thingy at the side of the screen and chose Hide from the prefs, then tried to install the new beta 3. Everything seems to be working fine now.
Thanks for your (as usual) speedy responses. :smiley:

Thanks, DEVONrat! Your solution is just what I needed.

(Btw, the first error message I received was that the Sorter was in use, not Sender. After I clicked ok on that, then I got the MacOS was in use msg.)

I got the same messages and had success (I hope) with the advice above.

Is choosing ‘Hide’ from the Sorter drawer the same as quitting/deactivating the Sorter? Would it be useful to add “Hide/Show Sorter” to DT’s Tool menu?

Did you check the Dock menu of DT?