DTPO crash reporting procedure

I’ve just experienced a DTPO crash, which is I believe the first time that DTPO has crashed on me. I’ve pasted the first couple of lines from the crash report (from OS X’s Console app), and am just wondering if this is something that I should also email to support. Incidentally, the forum wouldn’t let me upload the crash report in .PDF or .rtf format.

I haven’t got the expertise to read the crash report, so I don’t know what caused it. I’m running a mid 2010 MBP, with the latest versions of Mavericks and DTPO installed. I have a 256gb SSD, 8GB RAM, my memory pressure graph is/was normal and I have no Swap Used.

I’m working quickly at the moment and creating c.20 to 30 new records per hour. These are .rtf files into which I’m copying and pasting material, mostly from .doc files but occasionally also directly from websites (where the Clip to Devonthink extension doesn’t work as the content is hidden behind a paywall). The crash occurred after I had highlighted a few lines in a .doc file and hit Cmd->c. Spinning beachball resulted for a few seconds, and then DTPO quit. Naturally I thought I had lost several hours of work but after restarting DTPO (and dismissing the irritating “database appears to be in use!” message) everything appears to be still there. I ran a verify and repair and encountered no issues. This is fantastic, and I’m very impressed with DTPO’s abilities in this respect (as in many others).

Any ideas as to why this crash occurred would be appreciated so that I can take steps to prevent a recurrence.

Process: DEVONthink Pro [79605]
Path: /Applications/DEVONthink Pro.app/Contents/MacOS/DEVONthink Pro
Identifier: com.devon-technologies.thinkpro2
Version: 2.8 (2.8)
Code Type: X86-64 (Native)
Parent Process: launchd [169]
Responsible: DEVONthink Pro [79605]
User ID: 501

Date/Time: 2014-10-11 01:28:30.843 +0100
OS Version: Mac OS X 10.9.5 (13F34)
Report Version: 11
Anonymous UUID: 70A4478F-A4FC-CEC0-03DC-A6D55E5CAF81

Sleep/Wake UUID: 5E10549C-D7A8-4624-8047-9F137B211BEE

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000018

VM Regions Near 0x18:
__TEXT 0000000100e17000-0000000101041000 [ 2216K] r-x/rwx SM=COW /Applications/DEVONthink Pro.app/Contents/MacOS/DEVONthink Pro

Application Specific Information:
objc_msgSend() selector name: mouseMoved:

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libobjc.A.dylib 0x00007fff9671f097 objc_msgSend + 23
1 com.apple.AppKit 0x00007fff8f945305 -[NSWindow sendEvent:] + 1229
2 com.apple.AppKit 0x00007fff8f8e61be -[NSApplication sendEvent:] + 975
3 com.devon-technologies.AppKit 0x000000010134ed55 -[DevonApplication sendEvent:] + 229
4 com.apple.AppKit 0x00007fff8f7369f9 -[NSApplication run] + 646
5 com.apple.AppKit 0x00007fff8f721783 NSApplicationMain + 940
6 com.devon-technologies.thinkpro2 0x0000000100e531af 0x100e17000 + 246191
7 com.devon-technologies.thinkpro2 0x0000000100e192e4 0x100e17000 + 8932

Please start a Support Ticket. In the Finder, press Command-Shift-G and paste in: ~/Library/Logs/DiagnosticReports. Send us the most recent crash report for DEVONthink (the date is in the filename).

Will do, thanks Bluefrog.

I’ve reported one crash I had with a PDF, thinking that it was a strange anomaly (I don’t remember it ever happening before), but it looks like DT Pro Office is completely broken for me when it comes to PDFs. When browsing through PDFs it often crashes, and when it doesn’t, double-clicking to open the PDFs will do the job. The only workaround for today seems to be exporting everything and using another program, which isn’t exactly ideal :frowning:

Is anyone else seeing this with Yosemite and the latest DT Pro Office update? If there are any suggestions for what I can do on my end, please let me know.

I am experiencing the same problem with various databases in DTPO since upgrading to Yosemite (10.10). DT crashes very often and is nearly unusable. I’ve tried to rebuild my databases, but there’s no effect on the crashing…
Any news or helpful suggestions?