DTPO fails OCR on everything and even crashes the app

Using a supported Canon LIDE 60. All OCRs turn into PDFs that the log shows as a failed import. In fact there hasn’t been a single PDF I’ve been able to import through this mechanism.

It seems in going back and testing all the 1.3betas, they never worked either.

How many people actually use this function? It seems to fail on everything and in some cases crashes as seen below.

Latest attempt with 1.3 final even crashed DEVONthink Pro Office:

Host Name: entropy
Date/Time: 2007-03-01 14:30:56.259 -0800
OS Version: 10.4.8 (Build 8N1051)
Report Version: 4

Command: DEVONthink Pro
Path: /Applications/DEVONthink Pro.app/Contents/MacOS/DEVONthink Pro
Parent: WindowServer [79]

Version: 1.3 (1.3)

PID: 2758
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0 libobjc.A.dylib 0x90a564c7 objc_msgSend + 23
1 com.apple.Foundation 0x92602931 -[NSInvocation invalidate] + 74
2 com.apple.Foundation 0x92602877 -[NSInvocation dealloc] + 34
3 com.apple.CoreFoundation 0x9080c0d4 CFRelease + 130
4 …von-technologies.foundation 0x00493874 -[SimpleAutoreleasePool release] + 462
5 …devon-technologies.thinkpro 0x00118a9e 0x1000 + 1145502
6 …devon-technologies.thinkpro 0x00119d35 0x1000 + 1150261
7 …devon-technologies.thinkpro 0x000e0b56 0x1000 + 916310
8 …devon-technologies.thinkpro 0x000dfd79 0x1000 + 912761
9 …ies.framework.DTKitchenSink 0x16b78caf -[DTProUtils importPDFFileAtPath:inGroup:withAttributes:proxy:] + 312
10 …nkpro.plugin.ScannerCapture 0x16c460fa -[DTIController attributesPanel:returnCode:contextInfo:] + 2366
11 com.apple.AppKit 0x933f67ee -[NSApplication endSheet:returnCode:] + 359
12 …ies.framework.DTKitchenSink 0x16b81686 -[DTPDFAttributesPanel setAttributes:] + 62
13 com.apple.AppKit 0x9336cd88 -[NSApplication sendAction:to:from:] + 107
14 com.apple.AppKit 0x9336cce1 -[NSControl sendAction:to:] + 101
15 com.apple.AppKit 0x9336ee91 -[NSCell _sendActionFrom:] + 168
16 com.apple.AppKit 0x93381671 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 1271
17 com.apple.AppKit 0x9339f25d -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 848
18 com.apple.AppKit 0x9339eb0d -[NSControl mouseDown:] + 757
19 com.apple.AppKit 0x9335c3af -[NSWindow sendEvent:] + 5279
20 com.apple.AppKit 0x9334e350 -[NSApplication sendEvent:] + 5023
21 com.devon-technologies.AppKit 0x003885c3 -[DevonApplication sendEvent:] + 83
22 com.apple.AppKit 0x93278dfe -[NSApplication run] + 547
23 com.apple.AppKit 0x9326cd2f NSApplicationMain + 573
24 …devon-technologies.thinkpro 0x000021b6 0x1000 + 4534
25 …devon-technologies.thinkpro 0x000020dd 0x1000 + 4317

In any case, DT Pro Office should not crash, so something is wrong.

Please locate a complete crash log associated with such an event at ~/Library/CrashReporter/DT Pro.crash.log and attach it to an email to Support, with a description of the problem.

Although my main scanner is a Fujitsu ScanSnap I also use a Canon LIDE 500F to scan from bound material such as books and journals, and OCR works very reliably.

I submitted an email to support@ with several screenshots of a test I just ran (simple scan of my day job business card using defaults (300dpi,Color Photo)) that also failed. It even fails when you drag from Finder (TemporaryItems) into DTPO, whereas it will open in Preview.app.

The CrashReporter Log was also attached, it happened when I attempted to scan using 600dpi, Text.

Hopefully this will get worked out pretty soon – the paper is piling up. :frowning:

Just received the crash log.

I noted that you are using several haxies. These modify OS X and we’ve often seen “unintended consequences” – problems – on computers that have installed them. I’ll hazard a guess that your OCR problems would go away if the haxies were removed. (I keep my operating system pretty much Apple stock.)

Your message has been forwarded to Annard for his analysis.

Yeah I know this is the simple kneejerk response… sigh I’ll have to keep a clean install around just to disprove this point.

I do know what you’re saying about haxies, as I’ve been around long enough to see them be the default source of blame despite the fact in 3 years of running them they’ve only caused a single problem with DEVON products (that being the UI display of the node graph in DEVONagent, which is also fixed now.) But expecting your users to engage in only a stock build of Mac OS X may be considerably ambitious.

I can point at other software out there (Virtue Desktops) that crashes on command when I use synergy2 (from sourceforge) – that’s not a haxie, but I’d find it rather dismissive if they asked me to not use synergy2 in order to use their product.

But take it with a grain I understand the concern being a developer of other product myself. It’s hard to be a developer debugging an inconsistent baseline period. I’ll try to find a consistent baseline just to address this though.

Anyhow, I’ve debugged the problem down to OCR scanning working fine, but no pdf file (created or otherwise) can successfully be imported.

I’ll excuse the crash in the meantime. Unfortunately the only other test platform I have is Leopard and it’s ppc versus the crashes here happening on Tiger/Intel, and I’m sure you’re not taking bugs for that [Leopard] yet.

It might help to give your users some extra debug information, instead of having to gdb attach processes… “Failed” is quite vague and I can glean absolutely nothing from /var/log/*

Thanks for forwarding the bug report to Annard despite your haxie concerns.

It’s a “kneejerk” response because of the frequency with which the problems disappear when haxies are removed. It’s not that the guys at Unsanity are bad programmers, but things that modify the OS are especially prone to causing problems whenever Apple tweaks their own code. That’s happened, for example, with FruitMenus causing problems after an OS update. If haxies are used, it’s important to keep them up to date. That doesn’t seem to help with ShapeShifter, though.

The vast majority of users would only be confounded by detailed error reports, and it often takes a very experienced review (i.e. by Christian) of the crash log to tie down a problem.

No, Christian isn’t ready for bug reports on Leopard, yet. But I hope you are having fun with it. :slight_smile:

Deinstall/Disable ShapeShifter and it will probably work.

Wow talk about eatting crow :slight_smile: Hehehe Thanks for hunting this down! I’ll leave this app as an exception to APE.

Just to update, I added DTPO to the Master Exclude list of the Shapeshifter APE and everything is back to normal. But I will probably remove it entirely as this no doubt has me seeing the light of the situation Bill has been trying to impart to me.

It’s just when you’ve been bitten once, now twice in a three year span – and I customize the hell out of this from Apple’s baseline (6-7 mail.app plugins, 5-6 safari plugins, tons of third party productivity tools, etc) it is probably astounding that this is only the second issue I’ve managed to surface… hence my stubbornness to blame APE out the gate.