DTPO locks up hard when importing large mailbox

I’m just in the process of doing my initial archive of Apple Mail into DTPO and I’ve had it lock up hard three times in a row now (I have to power down my Mac as the whole system hangs) while importing the messages.
The mailbox I’m importing is on my mac (Moved from an IMAP mailbox) and has just over 8000 messages in it. It would get to around 3100 messages and just hang. I left it overnight thinking maybe i was just taking a while. Could not force quit any apps, had to power down. Tried again as I had a few app open so I tried with nothing open. Same thing. I though maybe the mailbox was too large so I moved about 2000 messages to another mailbox and tried those messages and it has hung again. I’ve successfully imported a few smaller mailboxes (250 messages) but the large one is the one I really need to archive.
One thing that is odd is that after the import window loads the messages, the Date Received field is empty although the field does show in apple mail.
I’m going to try adding the mailbox to DTPO through Apple Mail instead of DTPO to see if that works but any suggestions would help.

Those are not too many messages. I have imported much larger mailboxes successfully. What is shown in the Console? You can send the information to support@devon-technologies.com.

As to the dates, my guess is that the date format of these messages is not up to the agreed standards and the current version of the Pantomime library doesn’t handle that very well. They are aware of this fact however and I hope that their next release will be more flexible.