DTPO not able to start ...


I have a massive problem with DTPO 1.3b2.

I´m not able to start it. When I click the Dock Icon, the starting window opens, the progress bar starts, but stops in the first half, (in the mode “intiliaze&check” (german: initialisieren und überprüfen), also the twinning coloured ball dissappears …

The prehistory: Everthing works fine, until I decided to try to download my Weblog with all the documents I have linked to on other sites (Call me crazy …)

This takes some hours, and in the end I had an archive with 25.000 files in my DTPO database.

I decided to delete it. I try to delete this archive in a whole by pressing the delete-icon. But after a while DTPO crashed.

I started again, everything was fine. I try to delete it in parts, which works most of the time. Sometimes it crashed and I found, that was because of specific files.
So, I try to avoid this files during the deleting process firstly (although I cannot say which ones exactly).

In the end I had some groups, one with more than 2300 files and another one with 450 file, and I tried to delete the last one, but then it crashed, again.

I tried to restart, but then it happend what I described in the beggining. I restarted the whole computer (iMac G4, 1,25 Hz, 1,25 GB RAM, MacOS X 10.4.8 ) but wih DTPO it was the same result.

I download DTPO 1.3b2 agin from your website and install it. Than tried to start it, and once again: it stopped in the initialize&check phase.

What can I do?

Until now I´m a very satisfied userm but I think I reached the borders of the system …

If your database is very large, the initialization might need some time especially if there’s not enough RAM.

But you could also try this:

  1. Create a copy of your database in the Finder
  2. Select the copied database, open the contextual menu and choose “Show Package Contents”
  3. Select one of the backup folders inside the package and copy it to the desktop
  4. Copy the “Files” folder from the package into (!) the copied backup folder
  5. Add the “.dtBase” exension to the copied backup folder
  6. Now open the copied backup folder in DT Pro by double-clicking on it

Dear Christian,

thanks for your fast reply.

I will wait a while during the initialize and check mode.
If this doesn´t work I try what you´ve proposed.

I will come back and report what happened.

Thanks. Nice sunday

Dear Christian,

I found that my database is 1,79 GB big. This sounds like very big database.

I have a iMac G4, 1,25 MHz, 1,25 GB RAM.

The starting lasts now one hour, is this okay, or a sign, that something works totally wrong?

I haven´t done the procedere that you propose, but I will, when you say, that it make no sense to wait longer.


I don’t think that it will make sense to use this database in the future. The database might be fine but if there’s not enough RAM, the activity of virtual memory will decrease performance around 100 times.

I did the procedere with the Backup.0

it works, but this is an vey old version of my database which has a lot of files left.

Is there any possibillity to delete the rest of my (web)archive of my weblog, that I downloaded with the download manager, manually, so, that I have my database like it was before i try to do this crazy thing?

I did it now with the other backup in the folder, which is not so old.

(what does this teach me: make backups!)

Okay, but once again. Do you you see any possibillity to get my latest version of my database without this damned 25.000 files/objects archive of my website?

This would be nice, because since the backup version I collect some important papers in the database and deleted them from my harddrive.

Thanks for your patience on a sunday afternoon.

okay, I found in the Files-folder all my files that I collected recently (until 19. January).

Would it be possible to take the important files and drag and drop them in the backup database which I created through the procedere you told me?

And finally: this backup.dtBase on my desktop, What do I do with this?

Drag and drop it in the place where my databases are and then delete the other one and its copy? My original database called “Wissen1.dtBase” and the copy “Wissen1 Copy.dtBase”. The new “backup.dtBase” on my desktop was created out of the Backup and the Files-Folder of the “Wissen1 Copy.dtBase”.

Dear Christian,

I did it like I described it in my last post.

Now it works again. I´ve learned my lesson (make backups). Although I´m not sure, wether I have all the recently added files in my database back, I suppose most of them. I backup the old (huge) database somewhere at the external drive, so that I could search again the files folder when something is missing.

Thanks for your effort and sorry for disturbing on sunday.


That’s good to know.

You could copy the latest files from the old “Files” folder to the desktop and then import them into your new database. Already existing files should be marked as duplicates.