DTPO + Safari Clipper = Blank Page

Hi All,

When using the PDF clipper from Safari to DTPO (2.9.10), it only successfully captures once. Any subsequent times result in a PDF without text (i.e., a blank page PDF).

The only remedy I’ve found is to quit DTPO, and then captures works again… once. At which time I have to repeat the process.

Has anyone else experienced this behavior? Is this a known bug?

DTPO: 2.9.10
OS X: 10.11.6
Safari: 9.1.2


Same setup as yours (OS X, DEVONthink Pro Office, Safari), I am able to clip this page to PDF multiple times in a row.

Have you tried rebooting? Or uninstalling and re-installing the clipping extension.

Hi korm,

Thanks for your suggestions.

I already re-installed the clipper, but now tried a reboot. Now it captures multiple blank pages (rather than just one) the very first time.

After some more troubleshooting I narrowed it down to the “Reformat with Instapaper” option (sorry, I should have specified this).

When trying to capture to PDF (one page or paginated) with the Instapaper option selected the pages repeatedly come out blank. They are fine otherwise.

Is it repeatable on your system?


Nope. Cannot reproduce. With the Instapaper option on, I get a PDF “simple formatted” with Instapaper.

Of course, you know what site I’m testing, but we don’t know what site you’re testing – so it’s hard to play along 8) If you are clipping something behind a paywall, or with very strong anti ad-blocking, the site itself might not be delivering up the data needed to produce the result you want. DEVONthink, of course, cannot control what 3rd party site designers do with their stuff.

Strange. I’m testing with the address you supplied (plato.stanford.edu/entries/spin … hological/), so we’re on the same page there (pun intended). But not sure why we’re getting different results.

The Instapaper formatting works with webarchive, but I’m still consistently get blank pages with PDF one page and paginated. Although, both PDF captures work when capturing a webarchive already inside DTPO.

But from Safari, still no dice. Any other ideas?


So, interesting, I tried this on Chrome (with Instapaper chosen) and got a very long blank page. Same site. So, I guess I can randomly reproduce.

It’s particular to Safari. and is occurring in Safari 10 in macOS Sierra.
Chrome works.

Actually, the OP has El Capitan (per their original post), not Safari. And it doesn’t work in Chrome (per my last post – and earlier I noted I am using the same configuration as they are).


If you clear the cache using DEVONthink > Clear Cache and restart the program, you might have success. The issue I had with the Clipper in Chrome (using the test site you and I had bad luck clipping), both yesterday and today, is cleared for me if I clear the cache.

Thanks for the suggestion, korm.

Clearing the cache and restarting DTPO corrects it for the first capture; subsequent captures result in a blank page (or multiple blank pages if paginated), until I repeat the clear/restart process. Thanks again for your help!

@BLUEFROG can this bug be looked into for correction?