DTPO - Saving pdfs from websites & hyperlinks

Saving pdfs from a website into DTPO inbox does not automatically pull the hyperlink associated with the document download. I have to manually enter this for each item downloaded which becomes cumbersome and time consuming. Is there a way to have the hyperlink automatically pulled and associated with a downloaded document? It seems to do this when using the “Clip To DevonThink” web browser plugin for saving webarchives so the functionality must be there somewhere?

Also is there a way to save documents directly from a website into DTPO folder rather than saving to inbox and then having to move to a chosen folder location within DTPO?


You could print the PDF document to DEVONthink or add it via Clip to DEVONthink.

Selecting print does not provide me with an option to save to DTPO, either by trying to save by hovering over a pdf or from the safari menu.
I tried clip to Devonthink as a pdf but this produces a blank single page document. How would you save this example legislation.gov.uk/uksi/2014 … 689_en.pdf direct into DTPO and is there a way to bypass saving to the Inbox with an option of saving to a specific folder within DTPO like via ‘clip to Devonthink’?

Ensure that DEVONthink > Install Add Ons… > PDF Services is installed, and then from any OS X Print dialog select “PDF” in the lower left corner of that dialog, and choose “Save PDF to DEVONthink Pro”. Depending on your configuration in DEVONthink > Preferences > Import > Destination the PDF will go to the Global Inbox, the Inbox of the current database, or a location that DEVONthink prompts you for at the time of import.

Ensure that the extension your want to use is installed with DEVONthink > Install Add Ons… > Browser. When a PDF is displayed in the browser, click the Clip to DEVONthink button in your browser toolbar. The dialog that opens asks several things, including “Format” (choose PDF), Title, URL (should be filled in automatically), Tags, and the destination in any group in any currently open database can be chosen from the dropdown menu at the top.

Configured as above, the PDF displayed by Safara at the URL you provided is clipped to the destination I choose, with the URL in that PDF’s URL bar. No problem.

I have the extensions all installed but only ‘clip to Devonthink’ shows in my Safari browser. When trying to save I get the following:

With ‘clip to Devonthink’

additional attachment to follow on next post

continued from last post because reached max 3 attachments;

I have tried pdf paginated which also produces a blank pdf but you say yours produces the complete pdf?

Also, any tips on reducing image sizes for uploads to this forum welcomed as mine appear far to large…

I have no problem saving the PDF at that link (or any PDF displayed in Safari) using Clip to DEVONthink.

I don’t recognize that print dialog – never seen it in Safari. What OSX version are you using, or do you have a custom print dialog installed with your Brother printer?

This is the standard OS X (Mavericks) print dialog, with the PDF menu accessed at the lower left corner.

There are 2 ways to save the pdf I have been using. One is the way I posted which by following the previous sample pdf link and hovering over the lower middle section of the Safari screen it brings up a save/print options box, which then brings up the print screen. The second is by going to file-print in the browser and I see clicking bottom right ‘pdf’ drop down bow it gives me the option to save to DTPO (I missed this before);

It allows me to produce tags and includes the hyperlink but still produces a blank document / pdf though. If you notice on the above screenshot my document in the print/save pdf screen is blank which is probably the reason why it’s saving as a blank document. I haven’t changed anything and only selected to save the document. The only workaround I currently have is to save the pdf to my desktop and then transfer into DTPO which is not ideal. Are you using any additional steps / setting when saving pdfs from the web?

Not sure what you mean by “hovering” the cursor.

If the Web page to be captured is being displayed in Safari, press Command-P to invoke the Print panel, click on the PDF button, then on the option Save PDF to DEVONthink Pro.

I described above exactly what I do.

I press the Clip to DEVONthink button. Make sure the dialog is set to save as PDF, and then press “Clip”.

I’ve never had a problem, blank PDF, etc. It’s never not worked as designed.

As Bill mentioned, you can print to PDF but IMO the clipper is the fastest route.

hovering over the bottom middle section of a website page in Safari like legislation.gov.uk/uksi/2014 … 689_en.pdf provides a temporary box allowing save/print/next page per screen shot:

Using ‘cmd P’ allows saving to DTPO as follows;

However this produces the following error message:

Its then produces a blank version of the pdf shown in these previous posts. Any ideas?

Ah, Adobe enters the picture. You’ve installed Adobe Reader or Acrobat.

The first thing I do after installing Acrobat is to go to ~/Library/Internet Plugins/ and move Adobe’s PDF viewer to the trash.

OS X includes a PDF viewer.

Removing the Adobe plugin should eliminate your bug.

Tried that but did not work and still produces the following error message

All preferences in OSX have always been set to open pdfs / images in Preview and Adobe Reader has not been selected such as right clicking a pdf-selecting get info:

Any ideas?

If you have removed the Adobe file from Internet Plugins, try a Restart of the computer.

Deleted last post. There were two viewer files and both need to be deleted 1st tried only deleting AdobePDFViewer but problem still remained. 2nd deleted AdobePDFViewerNPAPI and problem fixed.
Thanks for the help.