DTPO Scribbler.app on upgrade to pb3.2?


I just upgraded to pb3.2, and (of course) tried out the OCR first thing. I got a notification that DTPO couldn’t find the Scribbler.app and OCR quit.

I had noticed on upgrade that the “Install ABBYY” option wasn’t checked: I assumed because I had been running pb3.

I went to re-run the OCR in order to get a screen capture of the alert, but the OCR worked the second time around.

Should I (we) have re-installed ABBYY on upgrade pb3 -> pb3.2?

Anything else we need to do?

Best, Charles

No, that’s not necessary. And can you send the information regarding the error from the Console (found in Applications > Utilities) to support@devon-technologies.com? Then I can check what caused this message to appear.

I had the same thing happen to me the first time. That was over 24 hours ago, so I don’t think I have the messages anymore. Worked fine after that fist time though.

Scribbler is a new version of the application and it is not a signed binary. As such, OS X demands you “okay” its launch as a security measure, before running it the first time. If you don’t OK the dialog, the app won’t launch and DTP won’t be able to find/use it. Given this dialog box can be hidden, this would cause this problem. It’s what I saw, when I noticed OCR wasn’t completing and DTP was effectively “hanging” with a beachball.

After first launch, when you click “okay” to let the application run, OS X will write a signature in the app and it can launch without issue.

The DEVON folks could get around this by signing the scribbler application binary, but it may be a bit of work to sign an application that’s a beta.

Signing it doesn’t solve that problem in my experience. I’ll see if somehow during our build process it gets quarantined.