DTPO: See also-issue with web server

I am currently playing around with the web server of DTPO (vers. 2.7.3, Mac OS 10.9.2, Safari) and wondering about an issue with the implementation of the “See also”-function. This works fine when I browse the database and single out a file there, but as soon as I try to go further, it stops working. The same happens if I search and then highlight one of the search results.
Is there a reason for this behaviour or do I miss something obvious?

Cheers,

Nils

What does “it stops working” mean? What is “it” – and what is not “working”?

In the server interface when you “See Also” the result is displayed in a new frame that overlays the current group’s document list (top right panel of the server’s display). There is an “x” in the upper right corner of that “See Also” result display which, when clicked, will close the “See Also” frame and return you to the document list you were viewing. “See Also” in the server doesn’t open a sidebar with the results – unlike with the DEVONthink app’s interface – but pressing the “X” has the same result as pressing the red button to close the “See Also” sidebar in the DEVONthink app.

Thanks for the explanation, korm! This detail eluded me. But still: Apart from the popping up frame nothing else happens when pressing the “See also”-button; the frame remains empty, despite the fact that in DTPO the “See also”-panel of the very same document is populated with hits.

Nils

Does “nothing happen” for every document in every database – or a few documents in one database? Database corruption is always possible - so performing a Verify & Repair, and Rebuild might be needed. First, though, make sure your database(s)’ preferences have “sharing” turned on. Rebooting frequently helps.

I have been unable to reproduce the same issue here. As Korm said does this happen on all document types?

Do you have any other safari plugins loaded? Some older plugins can interfere with the web application.

Thanks for the feedback!

As far as I can say: Yes (my database only contains pdfs and rtfs).

Thanks for the suggestion! I have deactivated all plugins but the behaviour persists: When clicking the “See also”-button after highlighting a document, the “See also”-panel popps up but remains empty.

Nils

Have you tried a different browser - Chrome, Firefox, iCab … ? Have you tried logging in as a different user and running the server in the other account?

Firefox, yes. But it makes no difference.

Yes, no difference.

While trying out the solutions suggested, I encountered even quirkier behaviour. I have tried the following:

• browsing the database:
-> highlight a document
-> press “See also”
-> pane popps up, shows correct results
-> highlight one of the new documents
-> press “See also”
-> nothing happens

• searching the database:
-> highlight a document of the results
-> press “See also”
-> pane popps up, is completely empty

• searching the database AFTER browsing and highlighting a different document:
-> highlight a document of the results
-> press “See also”
-> pane popps up, but shows documents which are related to the one highlighted during browsing!

So, for me “See also” seems to work (very limited) only while browsing, not searching. BTW, “See also” works as expected with the simple search interface.

Nils

The postings above seem to imply that See Also was never working over there – but your last post implies there are cases where it does work for you?

And nothing will happen in the server interface … this is what I described above: in the server, See Also results are in a separate frame and one cannot start a new See Also search from that frame. What you see is normal.

Yes, that’s normal.

Over here See Also-while-browsing is not “very limited” – I always get the same results as I do when doing See Also in a database.

Really? But there’s no See Also button in the Simple interface (the one accessed by clicking the magnifying glass icon in the upper left corner).

Okay, good to know. But to be honest, this behaviour is far from intuitive and not in line with the experience you get from the desktop application.

Yes, that is true, but you cannot go further from there as you can in DTPO (leapfrogging your database, so to speak). And I still do not understand why “See also” does not work for the search results.

But there is a link below the title of the document aptly named “See also”, and it works fine (“leapfrogging” the database). Unfortunately, the simple search interface is limited as it does not display the document, you have to download it. For that, the complex interface is better. However, I would like to see an implementation of a combination of the two: Good “See also”-results and “on the spot”-display of a document when highlighted. All the rest of the possibilities of the web server (editing, marking, adding) is not of interest for me (or my colleagues).
To be honest, I am not sure to which use case the current implementation of the web server is geared at. At least for my purposes (sharing pdfs in an academic environment via LAN), it does not seem to be the best possible.

Cheers,

Nils

Yikes :blush: I’ve never noticed that link! Thanks for the tip.